Why is Ping slow

Problem : one terminalserver has very slow ping times, 60 to 250 ms during working hours.
Slow to all ping destinations.
When users are logged off it is down to  1-2 ms again.
The server is very slow when running client server apps. (ERP) with client on TS and data on fileserver in same domain. When client and server both runs on either server it runs fine. No network issues found.
HostingManAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

F_A_H_DCommented:
have u tried with single connection ??
does it increase with the number of logging users ?
HostingManAuthor Commented:
Single connection on client server App. is also slow.
nomorefuzzylogicCommented:
When you say the other users are "logged off" do they actually turn off their PC's?
Do your pings ever lose responses when it is running slowly?
Is the IP address of the terminal obtained by DHCP or is it fixed? Is there another PC that could have the same IP?
Are you running on the same network - ie do all machines have the same netmask?
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

HostingManAuthor Commented:
All users are logged off the terminal server. ´
It does not loose response, just varies in answer time.
The server has fixed ip, there should be no ip conflict. will double check wehen I can close server though.
There are 2 networks but we have similar setups that works fine. Pinging either net is slow.
nomorefuzzylogicCommented:
The server has a fixed IP - does the server also act as the DHCP Server for the workstations or are they fixed IP as well?
Do you have a DHCP server on each network?
Do you have a single router between the 2 networks?
Is the default gateway defined by the DHCP server on each network? Do you have Internet access too? From both networks?
Where is / are your DNS Servers? One per network? Internet gateway?
When they log off from the TS do they also turn off their PC's?
F_A_H_DCommented:
sorry can u connect ur laptop directly to the server with ethernet cable and see the response

just to see if the network involved in the problem or not
HostingManAuthor Commented:
No, the server is virtual..
nomorefuzzylogicCommented:
Another quick thought - what are your ERP apps based on (I am thinking MS-Access so would be good to know)?
I understand that the client software runs on the Terminal Server and they access data on a File server - do you have 1 file server per network or is there just one? Also you say all runs fine when both client and server sides are run together on the file server.
Can you draw & submit an annotated network picture?
The-VikingCommented:
try to turn off TCP offloading on the  windows server  netvork adapter.
HostingManAuthor Commented:
It is a MS erp system (Navision) and a third party time registration app and they are both slow.

Can´t really draw the network setup.

It must somehow be network related i think, since pinging gets so slow response.
When ping is solved the apps will run fine i am sure.
The-VikingCommented:
turn off TCP offloading, and it will be fine... we had the same problem on 110 servers running on VMware.
The-VikingCommented:
EDIT: What  hardware and virtual software do you use?

EDIT2: You have to turn off tcp offloading on all servers that is having high requestrate. SQL, fileserver, appserver and TS.

HostingManAuthor Commented:
HP hardware and Hyper-V.
 I will try disabling tcp offloading on the network adapter.
(TCP checksum offload for ipv4)

Some suggest a reg hack to get rid of all offloading..

 Disable Offloading in Windows.
Use the following registry values to enable or disable task offloading for the TCP/IP protocol:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TCPIP\Parameters\DisableTaskOffload
Setting this DWORD value to ‘1’ disables all of the task offloads from the TCP/IP transport. Setting this value to zero enables all of the task offloads.


The-VikingCommented:
yes, u can use that... or you may also just change the network adapter settings directly.

You do use HP EVA and cisco network switches?
HostingManAuthor Commented:

I disabled the TCP checksum and lost connection for 5 sec.
There are users on server so I will try disabling something else on network device  like "large send offload" later.

HP MSA and HP switch.
The-VikingCommented:
can u send a screenshoot of the settings; i wil tell u what to disable.
HostingManAuthor Commented:
The-VikingCommented:
disable IPv4 Checksum Offload and TCP Checksum Offload (IPv4)

It wil give u some seconds of downtime, so dont do it in daytime :)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HostingManAuthor Commented:
I just wonder - should it be on guests only or also the virtual network card generated by hyper-v on the host ?
The-VikingCommented:
Try vm's first, then host...

HostingManAuthor Commented:
Thanks
diepesCommented:
When you experience the slow down on the vm, have you pinged the Host machine ?

Is it only the one vm that slows down, is the others on the same machine still fast ? (<10ms)
HostingManAuthor Commented:
After disabling IPv4 Checksum Offload and TCP Checksum Offload (IPv4)  on terminalserver,  today ping is normal 1-2 ms so it seems to have helped.  

The-VikingCommented:
Sounds good!

It's a strange problem that i often see on virtual HP hardware.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.