Secuirty Certificates - Exchange using SSL for OWA

Hi Guys,

Getting the certificate error when browsing to my OWA page :

https://owa.mycompany.com/exchange

Have my own CA have created and installed owa.mycompany.com certificate on my Exchange box.

All good so far, was expecting to get this error first time round due to it not being a trusted root authority in IE8.  Installed the certificate as a trusted root by the usual method  - View certificate - Install Certifcate, browse to the trusted cert folder -  install etc.....

Closed browser - restarted.... still getting error.  

Have checked my PC date and time, checked certifcate is valid ie expiry, owa name etc...  all looks ok.

I feel I am missing something obvious, but can't see it.

Anyone come across this before?  

IM.

PS One thing I have noticed is that the certifcate is not registered in TRusted CA tab in IE, its in the other peoples tab, even though I selected the trusted CA folder when I installed it.  Have tried on another machine, with the same results.

Thanks

IM
ianmclachlanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

reijerCommented:
Exchange 2007 and 2010 needs a trusted certificate. You need to request a certificate from a trusted certificate authority (verisign, comodo etc). It must be a multi domain certificate. (because of autodiscover).
Dmitriy Ilyinsenior system administratorCommented:
to add certificate CA to correct place you should select Local machine. By default certificate added to user account.
ianmclachlanAuthor Commented:
Hi,

Thanks for your reply.

Sorry should of said, its Exchange 2003.  However, I have just managed to fix the problem.  The two machines I tried it on had the same Windows7 OS - don't know if that is anything to do with it.

Anyway, it would appear that installing the certifcates from the browser to the Trusted CA folder doesn't work properly.  I manually installed the certifcate onto the machine, checked it was in the appropriate security tab on the browser - and it all works fine.

Happy Days !!!

Hopefully, this may help out anyone else.

IM

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ianmclachlanAuthor Commented:
This fixed the situation
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.