Almost there with SSRS & Sharepoint... possible IIS issues?

Systems:
Sharepoint 2010 with reporting services add-in installed to a Windows 2008r2 Web
SQL 2008 CU8 (this allows sharepoint 2010 integration) with SQL reporting services installed.

I have both servers installed as webfront ends with the SQL server acting as a the database server for WSS.

I can get my SSRS webpart to pull through to my sharepoint site successfully. My issue is that I can not save reports via Report Builder or Visual Studio 2008 to the reportserver so I can select them in sharepoint. I also can not browse the "reportserver" local directory on the web server and it returns back a "•This website requires you to log in." even though I have windows auth turned on in IIS7. This occurs when browsing from BOTH web front ends. I do have an issues with access mappings I know but I'm not sure how to map out the mappings as my primary webserver needs to be, well, primary.

Are there any places I can look at some logs or something to get some more details about the issue that could help diagnose the issue?
LeifHurstAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeifHurstAuthor Commented:
That solution does not appear to be valid for Sharepoint 2010.
LeifHurstAuthor Commented:
Resolved issue myself with the following solution:

http://msdn.microsoft.com/en-us/library/ee384252(v=sql.100).aspx

5.4 “The request failed with HTTP status 401: Unauthorized”
When you click Set Server Defaults, you receive the following error: "Server was unable to process request. ---> The request failed with HTTP status 401: Unauthorized."

Reasons:

The Reporting Services Web service is not configured to use Windows integrated authentication.
Note: The Reporting Services Web service must use Windows integrated authentication in SharePoint integrated mode. If it is set to Basic, Anonymous, or otherwise, it will not function as expected, if at all.
This message can occur if the following items are true:
You are accessing Set Server Defaults from another machine rather than from the Central Administration server directly.
Reporting Services integration has been configured to use Windows Authentication.
Kerberos authentication has not been configured correctly.
Reporting Services is installed on the same machine as Central Administration but the Reporting Services site is using a host header, and DisableLoopbackCheck has not been turned on. For more information, see section 10.1, “How to Change the DisableLoopbackCheck Registry Key.”
If the customer has more than one domain, verify that the SharePoint and Reporting Services service accounts and the user accounts accessing SharePoint are in domains that have a two-way trust between them. If there is only a one-way trust, there will be problems authenticating users and resources from both domains.
The Enable Integrated Windows Authentication option in Internet Explorer is not enabled.
Resolutions:

To change the Reporting Services Web service virtual directory to use Windows Authentication, follow these steps:

1.On the Reporting Services machine, open IIS Manager.
2.Locate the Web site that contains the ReportServer virtual directory.
3.Right-click the virtual directory, and then click Properties.
4.Click the Directory Security tab.
5.Under Authentication and Access Control, click Edit.
6.Make sure that only the Integrated Windows Authentication check box is selected.
There are two ways to resolve this:

1.Configure Reporting Services Integration to use Trusted Account instead of Windows Integrated. Follow these steps to change this setting:
a.Open Central Administraton, and then click Application Management.
b.Click Manage Integration Settings.
c.Set Authentication mode to Trusted Account.
Note: You will no longer be able to specify Windows Authentication for your report data sources, because we are not using Windows credentials. If this is done, you will receive the following error: “This data source is configured to use Windows integrated security. Windows integrated security is either disabled for this report server or your report server is using Trusted Account mode".

You can still specify specific credentials for the data source that are Windows credentials.
2.Configure Kerberos authentication, and then configure SharePoint to correctly use Kerberos authentication. (The overall configuration of Kerberos is documented in a large number of other resources and won't be specifically covered here. The following steps assume Kerberos has already been configured correctly. For more information about Kerberos and troubleshooting, see section 10.2, “Kerberos.”)
a.After Kerberos is configured, change the authentication providers on the SharePoint sites in order to be able to successfully use Kerberos.
b.Open Central Administration, and then click Application Management.
c.Under Application Security, click Authentication Providers.
d.Click the zone you want to modify.
e.Under IIS Authentication Settings. click Negotiate instead of NTLM.
f.Click Save.
g.Repeat steps iv-vi for each zone/site you want to change by selecting a different Web application from the drop-down list in the upper right hand corner.
Edit the DisableLoopbackCheck registry key using the steps in section 10.1, “How to Change the DisableLoopbackCheck Registry Key.”

To verify that integrated Windows authentication is enabled, follow these steps:

1.In Internet Explorer, click Tools, and then click Internet Options.
2.Click the Advanced tab.
3.Under Settings, scroll down to Security.
4.Make sure the Enable Integrated Windows Authentication check box is selected.
5.Close and then restart Internet Explorer.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LeifHurstAuthor Commented:
Solution was discovered on my own... supplied answer for future searches.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.