Windows 7 Group Policy Preference Drive Mappings with supplied username not working properly

We have a mixed Win7/WinXP & Server 2008 R2 environment with Drive Maps handled via Group Policy.  The drive maps to domain servers work fine, but we also have a few AIX servers with Samba shares that need to be mapped as well. These shares obviously dont have directory authentication so we have the GPs setup to just use a single username/password we configured in samba, which is fine for our security purposes on that share.  

The problem is that when the drives map on the Win7 machines at user login, they show up in Explorer as disconnected, and when the user clicks on the drive it requests the username and password for the share, even though we've explicitly configured the credentials in the group policy preference. If you type in the same credentials we've configured in the GP, the drive proceeds to connect and work just fine. We can't have the users have to retype credentials for individual drive mappings whenever they reboot.  Any ideas why the supplied credentials dont seem to work?  The XP machines dont have this problem.
LVL 5
valheru_mAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

brian_vt_hokieCommented:
Have you tried disabling SMB Signing?  We've run into similar issues with Windows 7 machines and non SMB 2.0 shares.  Disabling SMB signing has worked in most of those cases.  If not, you can also try disabling SMB 2.0.

[HKEY_LOCAL_MACHINE \System \CurrentControlSet \Services \LanManWorkstation \Parameters]
EnableSecuritySignature = 0 (Disabled = 0, Enabled = 1)
RequireSecuritySignature= 0 (Disabled = 0, Enabled = 1)

How to Disable SMB 2.0
http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm

1.Run "regedit" on Windows Server 2008 based computer.
2.Expand and locate the sub tree as follows.
HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters
3.Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)
Value name: Smb2
Value type: REG_DWORD
0 = disabled
1 = enabled4.Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.
5.Reboot the server.
valheru_mAuthor Commented:
Thanks for your response.

We've already got Signing disabled via Group Policy.
 Group Policy
I've disabled SMB2 as per your link, but the issue remains.  Other ideas?

Thanks!
ee_autoCommented:
Question PAQ'd and stored in the solution database.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.