Override OSX system short cuts

I am having trouble using Microsoft office products particularly the commands:
CTRL + H (to find and replace) in Word
CTRL or ALT + arrows to jump a word at a time

The problem is because they trigger 'higher level' Mac OS X commands that I'm unable to disable or find any way to turn off.
I have created a CTRL+H command in excel using the System Preferences/keyboard/shortcuts/application shortcuts. But this doesn't work for word (nothing happens - perhaps the command is not called "Replace" in word?)
I have switched off (unticked) the spaces command in the same system preferences, but this has made no difference, pressing Alt+arrows still triggers spaces. clicking it on or off in the system preferences makes no difference.
I don't know what to name a command to 'jumponewordleft' in order to add it to this preferences, but it's meant to be a built in feature of Word so should spontaneously appear if I can suppress or reduce the priority of the Mac OSX embedded shortcut.

I have no need or use for either spaces or 'minimise/close window'.
Is there any way to overcome this problem?
LVL 1
hawkeye_zzzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sigurdur ArmannssonDesigner Commented:
If you look into the menus in Word and Excel you will find that there are already shortcuts there ready to use. Find and Replace is Command+Shift+H. The Command key, CMD is used in most places where it would be CTRL on a pc.

Doesn't Alt+left/right arrows jump one word back or forth?

I suggest you look at Tools > Customize Keyboard in Word if you want to change or add your own keyboard shortcuts but use the System Preferences Keyboard Shortcuts rather for over-all commands, or to make shortcuts that some software can't add for you.

Hope this helps a little.
hawkeye_zzzAuthor Commented:
Sorry, that doesn't help at all.
I'm quite aware of those commands, they are the commands I'm trying to use - if you read my question you will see that these native word functions are being blocked by the higher priority system keycodes I'm trying to disable.
Sigurdur ArmannssonDesigner Commented:
Yes I have read it back and forth. The question it a bit complex (and English is not my native language) I am trying to find out what happens and why. Let me try to tackle this again.

Quote:
CTRL + H (to find and replace) in Word
CTRL or ALT + arrows to jump a word at a time

Is there a reason you rather want to use CTRL + H to find and replace is Word when Shift + CMD + H is the built in command inside Word? What higher level thing happens? In many cases, programs in mac version don't accept CTRL as a trigger key. What happens if you hit Shift + CMD + H in Word?

Quote:
I have switched off (unticked) the spaces command in the same system preferences, but this has made no difference, pressing Alt+arrows still triggers spaces.

You can disable Spaces altogether in the System Preferences, but under Exposé & Spaces, under the Spaces tab.

Quote:
I don't know what to name a command to 'jumponewordleft' in order to add it to this preferences,

When you use the System Preferences > Keyboard > Keyboard Shortcuts, you have to use the exact phrasing as it appears in the Menus. "jump one word left" and similar should be available to you soon as you stop Spaces.
Here is a great list of text managing shortcuts what work in most text oriented software on the mac:
http://www.apple.com/support/numbers/shortcuts/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hawkeye_zzzAuthor Commented:
OK this is good. By changing the controlling key in Expose/spaces system prefs to cmd instead of alt, (or disabling it there) that freed up the alt, and the jump-a-word is back working now in word. Great.

Regarding the CTRL H, this is the command I use in Excel, and on my PC in Excel and Word, so it's very irritating to press your habitual keys and dang! the window closes.

However I've now solved it. There is a Mac only menu item under Tools-customise keyboard, and there you can delete the pre-programmed keystroke and replace it, which i've now done, and all is working great now.

Many thanks
hawkeye_zzzAuthor Commented:
We got the solution between us.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.