SBS 2003 RWW problem with .net 2.0

We just took over a company with SBS 2003 RWW for their remote access.  They were not doing backups, so we installed a network attached HD for backups and the install software installs .net 2.0.  We did not realize there was a conflict with SBS and .net 2.0 but it has broken the RWW access.

I have uninstalled .net 2.0 and re-registered .net 1.1 but now when users access the secure site, they can get to the welcome page, but when you click on RWW they receive a "Directory Listing Denied
This Virtual Directory does not allow contents to be listed." error or simply a "permissions denied" error.  

Everything was working fine until the .net install.  so I don't think it has anythign to do with the ports on the router
wilsonmillerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

murgroupCommented:
You can run .net 2 on SBS 2003. What probably happened was it changed the default website settings to V2. Go to IIS manager and make sure the default website is using v1.1.4322.
it_saigeDeveloperCommented:
Make sure that the ASP.NET configuration for the RWW website is set to 1.1 in the IIS Manager and rerun the CEICW.

-saige-
wilsonmillerAuthor Commented:
@ murgroup:  How do I verify in IIS that the default website is using v1.1.4322?
Learn SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

it_saigeDeveloperCommented:
Open IIS Manager.  Start --> Control Panel --> Administrative Tools --> Internet Information Services (IIS) Manager
Expand the list of websites.
Right-click on your Default Web Site and select Properties.
Click the ASP.NET tab.
Select the ASP.NET version from the drop down list.

-saige-
wilsonmillerAuthor Commented:
I appologize for sounding like an idiot.   But the asp.net tab is not an option under the properties of the default website.  My options are:
Web Site
Perfomance
ISAPI Filters
Home Directory
Documents
Directory Security
HTTP Headers
Custom Errors
Server Extensions 2002


wilsonmillerAuthor Commented:
for the record, I did run aspnet_regiis.exe -i on the 1.1 version earlier today and tried re-runnign CEICW after but still get this error.  
wilsonmillerAuthor Commented:
I found the solution.  The default.htm for the default web page was missing the link to the login page.  Where it should have gone to ..\remote\logon.aspx, the file was overwritten to just go to ...\remote  

I am splitting the reward points between both of you, for the assistance.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wilsonmillerAuthor Commented:
The issue was resolved with an outside source and my resolution was posted as a follow up to close the post.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.