How to share/print files between a SBG900 modem and a lynksys router

I have a desktop computer with a printer that I want to share with 2 laptops. The deskop is connected to a linksys router, the router is connected to a sbg900 wireless modem, and the wireless modem connects my 2 laptops.   I know I need to set up something on my linksys router and possibly on the sbg900 modem.  Does anyone know how to do this.  Is it Port Forwarding on both devices? and how is it set up?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MipandAuthor Commented:
Please help!!
Fred MarshallPrincipalCommented:
I presume that you have this:
The cable modem / wireless router is connected to the Linksys router using the one ethernet cable on the modem AND that cable is plugged into the WAN/Internet port on the router.

Since you didn't say what the Linksys model number is, then I will have to presume that it is NOT wireless capable as well.

The simplest thing to do is this:

1) Access the router control panle and turn off DHCP for the LAN.  Make note of the IP address of the router.
Better yet, make the IP address of the router LAN side an address that's in the range of the modem LAN subnet.  That way you can still reach it easily after this change.  Make that change LAST.

2) Plug the ethernet cable from the modem into the LAN side of the Linksys.  Now you are using the Linksys as a simple switch.  No NAT, routing, gateway at all in this box.

Now your computer, if on DHCP i.e. "get an address automatically" will get its address from the modem and will be on the same LAN as the wireless computers / laptops.  
Now file and printer sharing should be the normal thing.
I'm expecting that the issue is that you have the Linksys router blocking the access.  I'm guessing that the physical connections are as follows:
Internet -- sbg900 -- LAN port on sbg 900 -- WAN (internet?) port on LInksys Router -- LAN port on LinkSys Router -- desktop computer.  Am I correct?
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

fmarshall is exactly on target.

Why are you using the Linksys router at all?  Isn't the sbg900 adequate?  If you are using it as a switch only, I'd strongly suggest purchasing an inexpensive switch instead of using a router.  MUCH simpler.
MipandAuthor Commented:
I should probably explain that the lynksys is being used for Vonage. (model: RT31P2)

Computer 1, printer, Phone - lynksys router (RT31P2) - SBG900 - laptops

The problem you have is because you have two local networks. The easiest way is to do the following:

Disable the wireless on the SBG900 and enable/create wireless network on the linksys router. This way all your devices (wired & wireless) will be on one network.

If you need more detailed help on both devices, please let me know.
MipandAuthor Commented:
i guess that would complicate using the lynksys router as a simple switch. I believe that would drop the phone from working
No worries. Then what you can do is flip the roles. Make the motorola the main router and just disable NAT in the Linksys. The vonage feature will still work because it doesn't care about the Local Network, it only cares about the WAN (internet). To disable the NAT feature on the linksys:

Log into your Linksys router Usually ( or in your browser. enter your usr/pawword. go to advance routing I believe. To disable NAT, click the Disable radio button. (When NAT is disabled, the DHCP server feature is also disabled.) With both the NAT & DHCP disabled your "router" is now a "switch" VOILA.. enjoy
Fred MarshallPrincipalCommented:
The Linksys RT312 doesn't have wireless.
I'm not sure that it won't work as I described.  It has 3 RJ-45 LAN ports - enough for the two that I suggested be used.

The key here is whether the VOIP connects to the internal switch function as I suspect it may.  If not, then the suggested approach won't work.
But then, if the RT31P2 is intended to perhaps take a public IP address then that would be the only choice I do believe....... for the VOIP to connect via a LAN address and go through the NAT.  

It's worth a try as no new hardware would be required and we can learn almost in real time if it works.. etc.
OH, and don't forget if you have enabled the firewall on the motorola then you may need to open some ports. Vonage requires the following:

Ports used by Vonage Adapters
The following ports are needed for OUTGOING Internet communications from the Vonage device to the Vonage servers.
DNS: Port 53 UDP
TFTP: Ports 21, 69, 2400 UDP
HTTP: Port 80 UDP
NTP: Port 123 UDP
SIP: Port 5061 UDP (used for older Vonage devices provisioned before 2005)
The following ports are needed for INCOMING and OUTGOING Internet communications from and to Vonage devices and servers.
RTP (Voice) Traffic: Ports 10000-20000 UDP. When a call is made, a random port between 10000 and 20000 is used for RTP (Voice) traffic. If any of these ports are blocked, you may experience one way or no audio.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lol, looks like we've probably confused you.

Okay. First setup the linksys with a static IP address.
Since the motorola is the gateway it should have 192.168.x.1*
So, your Vonage Linksys could be IP: 192.168.x.2, Gateway: 192.168.x.1, DNS: 192.168.x.1*
Now, that your done with that Disable NAT on the linksys. This will make your "router" into a "switch"

Go to your motorola, and put the Linksys IP Address 192.168.x.2* in the DMZ. This will make sure all traffic is open to that IP address.

* this value varies so make sure to check what number is the "X"

Once you have all this you should be able to receive incoming calls from the vonage, and be able to get a DHCP address from the motorola.
MipandAuthor Commented:
sounds good, I will attempt this.
Fred MarshallPrincipalCommented:
I thought the Vonage was already working.  That means it's going through the SBG900 just fine, no?  So, there should be no additional settings needed by switching the Linksys from a router to a switch.  If you already have port forwarding set up in the Motorola then that might need changing - but you didn't mention it......

There is no need to "disable NAT" on the Linksys as the WAN/Internet port isn't going to be used anyway.
And, disabling NAT is likely obscured by different terms like Mode: Gateway/Router, etc.
But, you DO want to disable DHCP on the Linksys LAN as I mentioned before.

Whatever the Motorola LAN address is, you will be able to find it out by looking at the laptops:
Start / Run / cmd
type in the command line window:

The "gateway" address will be the Motorola LAN IP address.
The laptop IP address will be in the same subnet as the Motorola's LAN address.
The subnet mask will almost certainly be - this means there are 254 usable addresses from .1 to .254 as in: to
The Motorola is likey but that isn't always the case.

The address assigned to the Linksys on the LAN should be outside the Motorola DHCP range.
The Motorola DHCP range may well be from .100 to .150 or .200.  So, make the Linksys address another that is NOT what the Motorola address is and NOT within its DHCP range.  
The addresses of the laptops would be a clue if you can't see into the Motorola settings easily.
If a laptop has an address or .102, .103, etc. then it's likely the Motorola DHCP range starts at .100 or .101 and its likely to have 50, 100 or 150 addresses.  
So, you pick an address for the Linksys that isn't in that range.  If this is a good example then you might pick
Or, if it starts at .50 then you might pick .49 and so forth. is always the same 9 numbers above and you will figure out what yours really are.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.