Link to home
Create AccountLog in
Avatar of lupodwdm
lupodwdm

asked on

BSOD on windows 7 x64 enterprise system. CUDA processing problem related to dxgmms1.sys

I have a 9800x EE system running on an Asus rampage II extreme motherboard with 6GB XMS 3 ram at 1600 Mhz.  The system is rock solid until I start to push it with my BOINC and CUDA work.  When I run they system with all 12 threads at 90% and at 3 GTX 470 the system will BSOD with the dxgmm1.sys error after an hour or two.  It is not a heat issue.  The cards never get above 70C and the processor never gets about 120f.  I have tried reinstalling the drivers in safe mode and even used 3d guru to clean out all the old drivers.  I am ruining the latest Nvidia driver.

Has anyone seen this type of issue before?

Avatar of ziad270
ziad270

Did you saw this post ?
http://nzgeek.org/blog/dxgmms1-sys-crash-blue-screen-of-death/
Tried all solutions ?
I have a feeling it's memory.

Download memtest86
http://www.memtest86.com/

If it all checks out, then update all drivers using Drivermax.  It's free.
 http://www.innovative-sol.com/drivermax/

PS.  What brand is your Nvidia card.  Tell me it's not a Palit?
This is a video problem. dxgmm1.sys is part of the graphics system. If you already have the latest driver, I would swap the card out and see if the error goes away.
Avatar of lupodwdm

ASKER

I'm running 3 EVGA GTX 470's in this system and 2 x GTX 470's in a dell XPS that's set up EXACTLY the same way.  I Have 0 problems on the XPS, only had been the expensive 980X system :(.  I already had the patch.  I just tried disabling C1 so well see if that helps.  I've swapped the cards also and it didn't seem to make a difference.  I think it's something with this Nvidia driver and my system.  If I run BOINC with the GPU's disabled it never crashes.  

I opened a ticket with NVIDIA and sent them all my info and the minidump to see if they had any thoughts.
Oh, and I tested the memory and it was OK but I swapped it anyway and that one tested OK too.
Here's something i  don't understand.  I don't think it's the cards.  I can enable SLI and play games for hours without a BSOD.  I can turn off SLI and run another CUDA project like DNET for HOURS without an issue.  (Cards all at 99-100%).  This must be something with BOINC or the drivers or something.

What size of power supply are you running. These GTX-470 have large power requirements. But since this error
only appears in a certain app I would think that the problem is BOINC. Can you get the previous release of BOINC and test that. Newest release may have some bugs.
I think I tried an earlier release.  I may try that again, but it will kill all my work units.  I'll see what I can do.  It's a 1200W PSU btw.
1200w psu should be plenty. sli capable requires lots of power. I think its the application version, try the earlier
version
Well, guess this will never get fixed :)
We never know. BOINC is an open source project so if you want to work on this issue you can get all the source code and try and fix this in the next version
Actually, people seem to be pointing more at Nvidia and the driver causing the issue than BOINC.
ASKER CERTIFIED SOLUTION
Avatar of lupodwdm
lupodwdm

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Found my own solution
turning off hyper-threading isnt a fix dude.  do a Bios update and it might fix it.  hyper-threading means ur not using the CPU to its potential and only using 60%.