Activesync not working

I have a client with SBS 2003. I was just kind of thrown into a situation without a clear answer as the precursors to the current problem. Where it stands now:

If I run the Exchange Connectivity test I get       Exchange ActiveSync returned an HTTP 500 response. I tried re-running the CEICW and it fails on the E-Mail portion.

I tried recreating the virtual directories as defined in KB 883380. That did nothing. I was looking at the directory security for Exchange and noticed that I cannot click 'select' next to Default Domain and Realm. The option is grayed out.

I will be happy to post any logs or other info to help but I am out of options.
adj1984Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

adj1984Author Commented:
Another note: an iPhone will setup on Exchange just fine but will not sync. Probably makes sense given the error, just wanted to add that.
D_VanteCommented:
adj1984Author Commented:
Thanks for the feedback but I don't think I'm having an OMA issue like that deals with. I will check through it just in case.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

Viral RathodConsultantCommented:
Can you refer the following article from alanhardisty and make sure you are not missing anything

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html
adj1984Author Commented:
Should I just not worry that the 'select' buttons are grayed out next to the default domain and realm and type them myself?
adj1984Author Commented:
Yes I have verified against that article. When I try to turn Forms Based Authentication back on now I get an RPC error based on 800706ba.
dennywayne1Commented:
I have configured ActiveSync on several 2003 Exchange servers with Forms Based authentication. You need to create a new "virtual" directory in IIS. The following link has the instructions -  
http://www.petri.co.il/problems_with_forms_based_authentication_and_ssl_in_activesync.htm
ash007Commented:
you can follow method 2 of article-kb 817379
Alan HardistyCo-OwnerCommented:
The HTTP 500 error suggests you need to follow KB883380 (delete and re-create the Exchange Virtual Directories).

With SBS 2003 - the Exchange-oma virtual directory should already exist, so there should be no need to run through KB817379 as the directory should already exist.

The HTTP 500 errors are the nasty errors.

Can you (in IIS manager), right-click on the Exchange virtual directory and select Browse.  What happens?  Any errors or do you see mail for the Administrator through OWA.  Also do the same for exchange-oma virtual directory - do you see the OWA login screen using Forms-Based Authentication?  If you do - please login.  Any errors?  If no login screen - what error do you see.
adj1984Author Commented:
I have followed 883380 3 separate times with no luck. OWA is working just fine although now that form based authentication is off I don't get a logon screen just the username and password box. Logging in and using OWA works without incident for all users.
Alan HardistyCo-OwnerCommented:
Okay - if you have followed KB883380 and have exchange-oma and logging in via OWA works happily, have you followed the other HTTP 500 possible solutions in my article?  If you have, then the next step is to download and install:

Microsoft XML Parser (MSXML) 3.0 Service Pack 7 (SP7) using the link below

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=28494391-052b-42ff-9674-f752bdca9582&displaylang=en

If that fails, you can either wait until the 4th January when I hopefully close a similar case with Microsoft and update my article / this post, or contact Microsoft directly and get their assistance.

The MSXML parser has not resolved the problem I am working on with Microsoft.
adj1984Author Commented:
Just downloaded and installed that. Nothing changed for me. I have tried all of the things that I could from your other instructions. As stated above turning off Forms Based Authentication seems to be a change I can't come back from. I can't shake the feeling that the fact that the 'select' buttons are grayed out is telling me something. None of my other SBS servers do that.

I ran the test on the store that you described as well and it found errors the first time and is now coming back clean but nothing has changed.
Alan HardistyCo-OwnerCommented:
Bearing in mind the Connect To The Internet Wizard fails, can you please download and run the SBS 2003 Best Practises Analyzer and see if that flags anything up:

http://www.microsoft.com/downloads/en/details.aspx?familyid=3874527A-DE19-49BB-800F-352F3B6F2922&displaylang=en

I'll hopefully have a next step or two on the 4th after speaking to Microsoft (and I have another HTTP 500 error that I am working on for an SBS 2003 customer in Ireland that might benefit from the phone call on the 4th too!)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
adj1984Author Commented:
I have been running the best practices tests and have been getting numerous DNS errors. When I run DCDIAG /fix I get the log below. When I run netdiag /v /fix it gets stuck on Testing DNS. I noticed there was no DNS entry for the DC in the DNS which I know is a problem. I manually added it but it doesn't seem to be helping. Is there a way to rebuild DNS on SBS?


C:\Program Files\Support Tools>dcdiag /fix

Domain Controller Diagnosis

Performing initial setup:
   Done gathering initial info.

Doing initial required tests

   Testing server: Default-First-Site-Name\REDDC
      Starting test: Connectivity
            *** Warning: could not confirm the identity of this server in
               the directory versus the names returned by DNS servers.
               If there are problems accessing this directory server then
               you may need to check that this server is correctly registered
               with DNS
         ......................... REDDC passed test Connectivity

Doing primary tests

   Testing server: Default-First-Site-Name\REDDC
      Starting test: Replications
         ......................... REDDC passed test Replications
      Starting test: NCSecDesc
         ......................... REDDC passed test NCSecDesc
      Starting test: NetLogons
         ......................... REDDC passed test NetLogons
      Starting test: Advertising
         ......................... REDDC passed test Advertising
      Starting test: KnowsOfRoleHolders
         ......................... REDDC passed test KnowsOfRoleHolders
      Starting test: RidManager
         ......................... REDDC passed test RidManager
      Starting test: MachineAccount
         ......................... REDDC passed test MachineAccount
      Starting test: Services
            IsmServ Service is stopped on [REDDC]
         ......................... REDDC failed test Services
      Starting test: ObjectsReplicated
         ......................... REDDC passed test ObjectsReplicated
      Starting test: frssysvol
         ......................... REDDC passed test frssysvol
      Starting test: frsevent
         There are warning or error events within the last 24 hours after the
         SYSVOL has been shared.  Failing SYSVOL replication problems may cause
         Group Policy problems.
         ......................... REDDC failed test frsevent
      Starting test: kccevent
         ......................... REDDC passed test kccevent
      Starting test: systemlog
         An Error Event occured.  EventID: 0xC0002715
            Time Generated: 12/29/2010   20:07:04
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:45
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:45
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:45
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:45
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:45
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:45
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:45
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:45
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:45
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:46
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:46
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:46
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:46
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:46
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:46
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:46
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:46
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:46
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:46
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:47
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:52
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:52
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0x00000014
            Time Generated: 12/29/2010   20:18:52
            (Event String could not be retrieved)
         An Error Event occured.  EventID: 0xC00003EA
            Time Generated: 12/29/2010   20:19:35
            (Event String could not be retrieved)
         ......................... REDDC failed test systemlog
      Starting test: VerifyReferences
         ......................... REDDC passed test VerifyReferences

   Running partition tests on : ForestDnsZones
      Starting test: CrossRefValidation
         ......................... ForestDnsZones passed test CrossRefValidation

      Starting test: CheckSDRefDom
         ......................... ForestDnsZones passed test CheckSDRefDom

   Running partition tests on : DomainDnsZones
      Starting test: CrossRefValidation
         ......................... DomainDnsZones passed test CrossRefValidation

      Starting test: CheckSDRefDom
         ......................... DomainDnsZones passed test CheckSDRefDom

   Running partition tests on : Schema
      Starting test: CrossRefValidation
         ......................... Schema passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... Schema passed test CheckSDRefDom

   Running partition tests on : Configuration
      Starting test: CrossRefValidation
         ......................... Configuration passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... Configuration passed test CheckSDRefDom

   Running partition tests on : redtrans
      Starting test: CrossRefValidation
         ......................... redtrans passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... redtrans passed test CheckSDRefDom

   Running enterprise tests on : redtrans.local
      Starting test: Intersite
         ......................... redtrans.local passed test Intersite
      Starting test: FsmoCheck
         ......................... redtrans.local passed test FsmoCheck
adj1984Author Commented:
Wow, I actually fixed the issue with DNS and things seem to be working better. The CEICW still fails although it takes a lot longer for it to do so. I am getting a bunch of these errors though and still have the HTTP 500 when I do the connectivity test.


Event Type:      Error
Event Source:      Server ActiveSync
Event Category:      None
Event ID:      3005
Date:            12/29/2010
Time:            10:17:40 PM
User:            REDTRANS\callison
Computer:      REDDC
Description:
Unexpected Exchange mailbox Server error: Server: [REDDC.redtrans.local] User: [callison@redtransportation.com] HTTP status code: [501]. Verify that the Exchange mailbox Server is working correctly.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
dennywayne1Commented:
Have you followed the instructions on the article I submitted earlier? ash007 also supplied an article which is the same as the one I submitted, just a different site. Naming is different, but you can call the new virtual directory anything you want.
I went to your exchange OWA and "Forms Based" authentication is still in use it appears. This is more pleasant for the end user but for ActiveSync to work, you must create a new "Virtual Directory" for ActiceSync.
Links/KB supplied in earlier posts- http://www.petri.co.il/problems_with_forms_based_authentication_and_ssl_in_activesync.htm
or
kb 817379
adj1984Author Commented:
The problem is now fixed. After fixing the DNS issues, I noticed that for some reason the Exchange-OMA directory was missing. I had made a backup of the Default Web Site before starting with those articles yesterday. I restored and it is now functioning fine.
adj1984Author Commented:
Although this problem had several different issues to be fixed, having me run the Best Practices Analyzer was the single best idea that and led me to all of the actual solutions.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.