Cannot ping Hyper-V VM from the network or access any Rolls when the Windows Firewall is turned on.

I setup a Hyper-V VM on Windows Server 2008 R2.  The VM can access the Internet and can also ping the Domain controller and other systems on the network.  The problem I am having is I cannot ping the VM or access any Rolls such as Remote Desktop Server from any system on the network, unless I turn off the Windows Firewall.  All access is one direction.  What are the correct Windows Firewall settings for a Hyper-V VM, because I don’t have this issue when I setup a standard (None VM) server?
TechAKAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sfossupportCommented:
What type of networking did you setup under hyper-v. Are you sharing the ip address.
Virtual networking and switches are a new concept unless you are familiar with vmware.
Here is a good description of virtual networking

http://blogs.msdn.com/b/virtual_pc_guy/archive/2008/01/08/understanding-networking-with-hyper-v.aspx
Darius GhassemCommented:
You need to open the ports within the Hyper-V VM.
brian_vt_hokieCommented:
If you're going to keep Windows Firewall enabled, then you'll need to create exceptions for all inbound services/ports that you want to allow.  Remoted Desktop/RDP (port 3389) sounds like it's one you need.  If there are others, like File and Printer Sharing (if you have file shares on this machine), just go into the Windows Firewall exception list and add them.

Or you could turn Windows Firewall completely off, depending on your security needs.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TechAKAuthor Commented:
I was able to allow ping by running the following command from this
Website: http://www.petri.co.il/enable-ping-windows-2008-server.htm

Enable ICMP Replies via the local Command Prompt
Open and elevated command promt

To Enable Run:
netsh firewall set icmpsetting 8

To Disable Run:
netsh firewall set icmpsetting 8 disable
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Virtual Server

From novice to tech pro — start learning today.