Link to home
Start Free TrialLog in
Avatar of SCS-Enzo
SCS-Enzo

asked on

My OWA for Exchange 2007 only work when I am remoted in with GoToAssist Express

We had our old server crash it was running Windows 2003. We upgraded the server now we are running Windows 2008 small business server with exchange 2007. Everything on the network works great except for the Outlook web access it works on the internal network fine but not outside of the network. I started running into the problem when I was connecting the bosses blackberry using Outlook web access it didn't want to of verify and then it would, two days later or so it would unverified very frustrating  this is been going on for weeks. I have called blackberry multiple times they are useless Today I connected my iPhone I noticed that the only time the e-mail was consistently coming in was when I was remoted in with GoToAssist Express, I don't know if it's just the act of being logged into the server or the GoToAssist Express but it makes it work I can't figure out why. I have been working with this problem for three weeks now and hoping that it is something easy to fix.

please help

I've opened all these ports on the router I'm not sure if I'm missing any...

•      Port 25 TCP – SMTP (Outgoing Exchange e-mail)
•      Port 80 TCP – HTTP
•      Port 443 TCP – HTTPS (RWW, OWA, remote desktop or Terminal Server sessions)
•      Port 987 TCP – External secure Companyweb access
•      Port 1723 TCP – PPTP (VPN)
•      Port 3389 TCP/UDP – RDP
•      Port 143 TCP/UDP – IMAP
•      Port 135 TCP RPD EP
•      Port 55001 TCP RPD CA
Avatar of dennywayne1
dennywayne1
Flag of United States of America image

Have tried disabling IPV6? Exchange 2007 and OWA does not support it.
ASKER CERTIFIED SOLUTION
Avatar of dennywayne1
dennywayne1
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of SCS-Enzo
SCS-Enzo

ASKER

I used this website...
http://support.microsoft.com/kb/929852

Before your second post.

But in value data it will not let me enter "0x20" it changes this one to "4120"or "0xFFFFFFFF" "it changes it to 41ffffff is that ok I dont think it is???

Uncheck Internet Protocol Version 6 (TCP/IPv6) in connection Properties was successful.

Restarting now

In the hexadecimal, just enter FFFFFFFF. It will not accept 0x..... but after you click OK, 0xFFFFFFFF will be displayed
On the network tweaks how and where do you remove"::1 localhost+ from the HOSTS file

I have done everything else I will give a hour or so to see if it work. Exchange is working and they are getting there email with the changes on the LAN. So far I cannot log into the Outlook web access or even load the webpage but I will give it an hour or so.
If you try to use OWA from outside using a computer instead a BB or iPhone, do you get the IIS7 welcome page?  I used to have the same problem and it was about the SSL Certificate.
No I get Internet Explorer cannot display the webpage.

We have our SSL Certificate installed.
Ok I am back to where I started Outlook web access only works if I am log in with GoToAssist Express otherwise I just get Internet Explorer cannot display the webpage.

I wonder if I'm missing a port on the the router.
What is a good way to test if the ports are open?
Your "host" file is located in c:\windows\system32\drivers\etc. Open with Notepad and place a # (comment) in front of ::1
Save and close.
do I need to restart the server after I change that?
If I remember correctly, IP V6 caused problems with ActiveSync and Outlook Anywhere? If you can't access OWA from the outside, it would appear to be an access rule or NAT on the router perhaps?
On the LAN, can workstations open OWA via "Public" URL or https://servername/owa?
OK that looks like it work!!!!!!!!!!!!!!!!!!!!!!!! YOU ARE THE MAN!!!!

What is IPv6 and why is causing me so much trouble.
Glad to hear it is working now. There are numerous articles on IPv6 which is supposed to replace IPv4 due to the fact that we are running out of IP addresses. IPv6 uses hexadecimal numbers similar to Mac addressing which is virtually unlimited.
As of yet, it has not been globally implemented as all routers in use do not support IPv6. It will take some time for IPv6 to implemented as the norm, and personally, I am not a big fan of it.
If you don't mind, could you award points? thank you
IMHO, you are wasting your time messing around with IPv6. The article linked to above by dennywayne1 is related to Exchange 2007 running on Windows Server 2003. IPv6 is supported on SBS 2008 in Exchange 2007 because it is a 2008 version of Server and because Exchange 2007 SP1 and above support IPv6 on server 2008.

  http://technet.microsoft.com/en-us/library/bb629624(EXCHG.80).aspx

That being said, if OWA works on the internal network, then it is working properly. If you cannot get to it from an external PC, then either you are typing the wrong thing into IE address bar, or there is an issue with your firewall. To get to OWA, you should be trying something like https://remote.yourdomain.com/owa. If that is not woring, you need to run the "Fix My Network" Wizard in SBS. And review your firewall settings. Be sure that 443 is in fact pointing to the IP of the new SBS server and not your old one.
Windows 2008 server and Vista, Windows7 listen on IPv6 by default. From any of these computers if you haven't disabled IPv6 and you ping localhost or computer name from said computers to itself, you will receive a reply with a hexidecimal number and not the IPv4 address. Once disabled, you will get the reply from IP address which you are used to.
Even if your router supports IPv6, getting it to work with your exchange server would require additional configuration.
sguinn100,

We are running Exchange 2007 on Windows 2008 Enterprise and although OWA, ActiveSync and Outlook Anywhere worked internally and externally initially, it did stop working. After disabling IPv6, we have had no further issues/problems. The exchange server is the only server in which I needed to disable IPv6. All other 2008 servers are using default settings for network connections.
Furthermore, Windows 2003 does not use IPv6.