Windows 7 Group Policy Preference Drive Mappings with supplied username not working properly

We have a mixed Win7/WinXP & Server 2008 R2 environment with Drive Maps handled via Group Policy.  The drive maps to domain servers work fine, but we also have a few AIX servers with Samba shares that need to be mapped as well. These shares obviously dont have directory authentication so we have the GPs setup to just use a single username/password we configured in samba, which is fine for our security purposes on that share.  

The problem is that when the drives map on the Win7 machines at user login, they show up in Explorer as disconnected, and when the user clicks on the drive it requests the username and password for the share, even though we've explicitly configured the credentials in the group policy preference. If you type in the same credentials we've configured in the GP, the drive proceeds to connect and work just fine. We can't have the users have to retype credentials for individual drive mappings whenever they reboot.  Any ideas why the supplied credentials dont seem to work?  The XP machines dont have this problem.

We have disabled SMB Signing via Group Policy as follows:
 SMB Signing
I have also disabled SMB2 on the Win7 client as suggested by brian_vt_hokie, but the issue remains.
LVL 5
valheru_mAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cesar AracenaPHP EnthusiastCommented:
Hi valheru_m,

The dirty fix: Execute net use x: "\\SambaServer\drive password /user:user" on each start-up with a batch file in the startup folder.

Better fix: Go to UserAccounts and under Manage your credentials you enter your server's name, username and password

Cheers.
brian_vt_hokieCommented:
Have you verified that SMB Signing is actually getting turned off on the clients?  I understand that it's set in GP, but is it actually getting applied?  Have you run RSOP to verify?
valheru_mAuthor Commented:
Caracena,

That would work on an individual basis, but we have about 200 machines.  This would need to be a fix that can be distributed.  While we could run the net use command via logon GP, it would seem to defeat the whole purpose of the supplied credentials in the GP Drive map preference.  Plus, the preference policy works fine on XP machines.  Is there a reason it's not working on Win7 only?  Again, the symptom is weird, the drive actually maps and the drive letter shows up in Explorer, but shows up disconnected (red "X" through it).  If you click on it and enter the exact same credentials we have in the policy, it maps and continues just fine. XP machines dont have to enter credentials at all, they just work.
Become a Microsoft Certified Solutions Expert

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

valheru_mAuthor Commented:
Brian, I'll check RSOP and post the results.
Cesar AracenaPHP EnthusiastCommented:
valheru_m,

You are right about the solution being innadecuate, but as Microsoft said, it is a bug in Windows 7 that generates because of the OS security changes from XP. Brian could be pointing toghuards a nice clean solution but Micrsoft suggest what I've suggested here. Look for it in the Microsoft support forums.
valheru_mAuthor Commented:
RSOP shows the policy being correctly applied to the stations for disabling SMB signing.

We've also tried the credential manager solution, but no dice there either.

I'm currently exploring changing the policy for the NTLM version in Caracena's link.  The testing started this afternoon but might not be finished til early next week.  I'll repost the result.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
valheru_mAuthor Commented:
More specifically, I've also found a group policy setting that's supposed to make the changes.  Details in the following link:

http://www.gadgetgrill.com.au/2009/11/19/windows-7-fixing-the-mapped-drive-credentials-problem/
valheru_mAuthor Commented:
No solutions provided have solved this issue.  It remains on the Windows 7 workstations and we have no solutions as yet.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.