RPC / Over HTTP issue

we have windows 2003 / exchange 2003 environment. We suddenly cannot configure anymore RPC/HTTP connections in outlook. when debugged using outlook /rpcdiag we get the attached screen in the outlook.

Any Help appreciated...

Wish you a Happy 2011 ahead to all...

SK
image003.jpg
principiamanagementAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

endital1097Commented:
check your registry for a missing entry for port 6004
HKLM\Software\Microsoft\Rpc\RpcProxy\ValidPorts

you should have an entry for the netbios and fqdn of all your mailbox servers for 6001-6002 and 6004
mail.contoso.com:6001-6002;mail:6001-6002;mail.contoso.com:6004;mail:6004
principiamanagementAuthor Commented:
hi thanks for your reply. I checked the rpc frontend and it does have both ports list for netbios and internal AD domain name (fdqn) but not actual internet email domain name? Should I also include the internet domain name for port 6001-6002 and 6004

SK
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

endital1097Commented:
no, the front end needs the server name that will resolve to an internal ip address for each back end server

principiamanagementAuthor Commented:
Yes the internal names of backend server is configured in the front end / rpc registry
endital1097Commented:
i would follow the article suggested by @R--R
i believe microsoft also has a kb on setting it up on a single exchange server

once you verify the steps taken you can run
netstat -ano | findstr 600

you should see your ip listening on 6001 6002 and 6004
verify that 6001 is associated with the store.exe process
and that 6002 and 6004 are associated with the mad.exe process
lastlostlastCommented:
1. Do you have any GC server running windows server 2000?
- If 'Yes' then RPC over HTTPS will not work. Decommission the Win 2000 server or point (hard code) exchange server to a Win 2k3 GC server.

2. Check the following registry key on the GC. If it is not present, then create it.
HKLM\System\CurrentControlSet\Services\NTDS\Parameters
Type: REG_MULTI_SZ
Name: NSPI interface protocol sequences
Value: ncacn_http:6004

P.S.: You will need to restart the GC server after adding the registry key for the changes to take effect.

Let us know how it goes.




Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
principiamanagementAuthor Commented:
It worked after creating the Reg entry in the GC ..

Bravo... Many Thanks
SK
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.