Link to home
Start Free TrialLog in
Avatar of cmhorvath
cmhorvath

asked on

How to I fix a Internet script error message when logging into Microsoft Dynamics Great Plains in Citrx?

Testing a new XenApp Server and when logging into Microsoft Dynamics Great Plains.  
Some users receive an Internet Explorer Script error message "The system cannot find path specified".

file://C;Documents%20and%20Settings/[UserName]/Local%20Settings/Temp/4/tmpD.tmp

Error message varies.
Avatar of Steve Endow
Steve Endow
Flag of United States of America image

Hi,

I haven't run into this issue in several years, but here is one workaround to try and avoid the error.   Which version of GP are you using?

Depending on which version of GP you are using, GP uses Internet Explorer to render and display the "Home Page".  The error you are seeing is due to some problem that IE is having loading the content.

One workaround is to try and disable the specific content on the home page that is causing the error.  If that doesn't work, you can disable the home page entirely.  

To do this, click on "Customize this page" in the upper right corner of the Home Page.  Start by unchecking one 'content' item, clicking on OK, then closing and re-launching GP.  If the error stops after you uncheck one of the content items, then you have found the particular item that is causing your problem.  If it still occurs when no content items are unchecked, then you can disable the home page by unchecking "Display home page when GP starts".  Another possible way to test is to close the Home Page by clicking on the X in the upper right corner, then clicking on View -> Home--but I don't know if that will fully refresh the temp files and trigger the issue for you.

Disabling the home page is not ideal, but it's a workaround.  

I don't know if there is a resolution to the issue--it could be a permission issue, or something more complex.  If you can post several more of the different error messages that you are seeing, I can try and see if one of them is documented.

Thanks,

Steve Endow
Dynamics GP Certified Trainer
Dynamics GP Certified Professional
Avatar of cmhorvath
cmhorvath

ASKER

The content item was unchecked.  but what seemed to resolve the issue was when the quicklaunch was added to the Application data folder.  Not sure if this resolved it for all users having this issue.  I will let you know was I have some other users test it.

Also, I am not sure if the User Configuration Group Policy from the old citrix server, which is in production, is following users when the logged onto the new server that we are testing.

Will keep you updated.
So what resolved the issue was putting the Launch Internet Explorer Brower in the Quick Launch folder resolved the isse.  So what was happening is this folder was not being created when users log on to Citrix.  So I added to the logon script to create this folder.  So, far this seems to be working.
Hi,

Wow, thanks for the update.  That is quite bizarre.  I have never seen that before, and can't explain why GP or IE would depend on that shortcut or directory structure (although it has been a while since I used XP and years since I tinkered with the Quick Launch folder).

So would IE launch independent of GP, or did IE get some type of error as well?

Thanks,

Steve Endow
Dynamics GP Certified Trainer
Dynamics GP Certified Professional
When you open GP via Citrix, it will give an IE error.  At first it looked as if it was some JAVA error.  As if the lastest version of JAVA was not installed.  To me that made no sense either that the quicklaunch would have anything to do with it.  Our citrix vendor will be on site on Wednesday and he has twicked a few things.  I will speak with him to see what he had done to ensure that what he did as well had some impact or not.
Cmhorvath, which GP version, and which Service Pack?
ASKER CERTIFIED SOLUTION
Avatar of cmhorvath
cmhorvath

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Well, glad to hear that your problem has been fixed, but I would have appreciated if you answer our questions at the same time.
Because the issue was resolved when not applying a group policy.