Link to home
Create AccountLog in
Avatar of perk83
perk83

asked on

OWA and Mobile email issue in Exchange 2010

Last night I setup a new Exchange 2010 server.  We were running Exch2003 so now I am in the middle of migrating mailboxes off the old and onto the new.  Email is coming and going fine for thos who have been moved to the new server as well as those who have not been moved and still reside on the old server.  The problem I am having is that I can not login to OWA.  I have a GoDaddy cert that I rekeyed for the Exch2010.  It is installed and says it is valid for exchange.  I have assigned services IIS, POP, SMTP and IMAP to it, but I still can't get OWA or my iphones to connect.  Any ideas?  One thing that seems strange to me is when I go to IIS on my  new 2008 RS box running Exch2010, I see the server name (mail), but nothing under it.  There are no default web sites or anything like I am used to seeing in Server 2003 with Exch 2003.
Avatar of perk83
perk83

ASKER

Looking around further at my server, I really think something may be messed up with my IIS.  When I launch the IIS Manager and select my server, "Mail (local server) I see nothing at all under it.  That can't be right.  When I right click on the server annd choose browse, I get an error message, "The server declined to show the web site".  I also get this error when I go to http:\\localhost.  Another observation is that the IIS Manager I have installed seems to be 6.0, yet the version listed when highlighting my Mail (local server) shows to be IIS 7.5.  What am I missing?  Thanks so much ahead of time.
> Regarding the certificates
If you are having a SAN cert. just include the URL of the E2k3 too
Then assign the same cert. on both the E2010 and E2k3 server

> Regarding the OWA V.directory
Check below the IIS7.5\Default Web Site
If nothing is there...try running the commandlets
--> get-owavirtualdirectory
--> New-owavirtualdirectory

Get-OwaVirtualDirectory
http://technet.microsoft.com/en-us/library/aa998588.aspx

New-OwaVirtualDirectory
http://technet.microsoft.com/en-us/library/bb123752.aspx



Also check if the OWA on E2k3 is working fine or not
Check for the http://localhost on the E2010 server irrespective of the IIS6.0 or IIS7.5
Avatar of seb_acker
Hello
Did you do all the steps to configure the "redirection" from 2010 to 2003 ? Exchange 2010 does not proxy to 2003, so you will have to use the set-owavirtualdirectory to set an external url for the 2003 OWA and activesync :

Set-OwaVirtualDirectory srv2k10\OWA*  -Exchange2003Url https://srv2k3.fdqnexternal/exchange

That means that you will have to setup your proxy / Certificates accordingly. If you wanna use single signon, you MUST use a proxy, and more, the poxy must listen for both exchange 2k10 and ex2k3 with the SAME listener.

For Activesync, you have one more thing to do :
Ex2k10 and ex2k3 must communicate through kerberos...
•      Install a hotfix. To download the hotfix, see Event ID 1036 is logged on an Exchange 2007 server that is running the CAS role when mobile devices connect to the Exchange 2007 server to access mailboxes on an Exchange 2003 back-end server. Use Exchange System Manager to adjust the authentication settings of the Exchange ActiveSync virtual directory.http://go.microsoft.com/fwlink/?LinkId=3052&kbid=937031
•      Set the msExchAuthenticationFlags attribute to a value of 6 on the Microsoft-Server-ActiveSync object within the configuration container on each Exchange 2003 Mailbox server. For an example script, see Server Build DVD Visual Basic Script Examples http://go.microsoft.com/fwlink/?LinkId=167205

Don't use IIS Manager to change the authentication setting on the Microsoft ActiveSync virtual directory, because the DS2MB process within the Microsoft Exchange System Attendant will overwrite the settings stored in Active Directory.
ASKER CERTIFIED SOLUTION
Avatar of perk83
perk83

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.