FM Privalege Set/Security Issue

I know this will end up being a simple question, but have been banging away at it for awhile.

I want to set up someone so that they can only modify one field in a db.  This has worked well in other dbs.  I started with all being Read Only, then selected "limited" and then select the field and select "modifiable."  However, it doesn't work.  They keep getting an error that says "this field is not modifiable."  

I then thought it must have been because it has a value list, but even after I made it so they could modify all value lists there was no change.   Yet, Browse mode has been checked AND there are no selections in the field's validation screen.  Any ideas?
-PrivSetIssue1.JPG
-PrivSetIssue2.JPG
LVL 2
rvfowler2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lesouefCommented:
this is not enough info to have a comprehensive view, there are other settings which can superseed what you show:
can you show the modifiable set details?
and the records "custom" values?
and remember the resulting rights are the least of all conditions.
TocacarCommented:
When you go to File/ Manage Accounts & Privileges, and you go to the Edit Privilege Set screen, then select Custom Privileges in the 'Records' drop down menu, the 'Custom Record Privileges' window opens.  Check that you have allowed editing on the record level (as well as the Field level, which you have already set).
rvfowler2Author Commented:
My screens are slightly different than yours as I am on v11.  Not sure how to allow editing on the record level unless you mean go into the Edit field in the screen below, and select "Limited."  However, it gives my a calc dialogue box, which I an unsure what to do with.  I did try to enter her privalege set name here, but it did not allow her access either.
-PrivSetIssue3.JPG
-PrivSetIssue4.JPG
Become a Microsoft Certified Solutions Expert

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

lesouefCommented:
from what I see, whatever you set as 'limited", it won't work as edit is disabled.
the resulting rights is an AND conditions in between all conditions

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TocacarCommented:
Can't you select 'Yes' in the Edit drop down menu instead of limited?  You first want to allow the user to edit records, then you want to specify the particular field(s) you want them to be able to edit (which you have already done, I think).
rvfowler2Author Commented:
Thanks, that worked.  And seeing the Security Rights as an "AND" condition makes sense and makes it easy to remember for the future.  Sorry, since I'm self-taught, every once in awhile I come up with these gaps in my knowledgebase.
lesouefCommented:
Most of us are self taught, don't worry, at least I am, last training I attended was 25 years ago!
TocacarCommented:
Never been on a training course myself either....  Glad you got it sorted.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
FileMaker Pro

From novice to tech pro — start learning today.