File Shares quit working on Windows Server 2000 file server

All of the file shares which have been used forever have quit working on our Windows Server 2000 file server.  We had a couple of viruses (win32.virut, trojan.adh, etc.) and after cleaning those off the shares no longer work.  I really need these, they are vital and I can't for the life of me figure out how make sharing resume.  New shares aren’t working either.  I tried setting up new ones to test with but can't connect to them either.  I'm wondering if a dll is corrupt or if a service I need is stopped (although I have checked those and everything seems okay there).  Any ideas would be appreciated.  Thanks.
aciadminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnb6767Commented:
Is the Server Service running on this server?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aciadminAuthor Commented:
Yes.  Interestingly my BackupExec software can talk to the server and the shares but that seems to be the only thing that can.  I can't map a drive the any of the shares from a workstation or another server other than the backup server.
mrhamenCommented:
Did the virus issue cause problems with the folder permissions? What happens if you go into Computer Management and look under System Tools\Shared Folders does it show the shares there?
CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

aciadminAuthor Commented:
When I look under system tools\shared folders the shares are there (all ten of them).  The permissions look correct when I view them.  From a command prompt if I type net share I see all the shares listed also.  If I try to use net use and map the drive that way, I get network path was not found, system error 53.  These shares have existed for years and haven't been modified in any way from my standpoint.  I am suspecting the virus has modified the share permissions somehow.  I couldn't run tsadmin earlier either.  The administrator rights were removed from the executable but once we put those back I could run it.  Somehow this is all tied together.  I'm just not sure how to make sharing work again.  
mrhamenCommented:
Depending on how complicated your permission structure was to begin with here is the kb aritcle on how to restore the default NTFS permissions on the windows 2000 box

http://support.microsoft.com/kb/266118

This might be the easiest way to start over with the permissions.
readydaveCommented:
Isn't there an option during a Backup Exec restore to also restore the NTFS permissions? Have you looked at that route?
aciadminAuthor Commented:
No.  I actually just got this fixed.  Turns out there was an IPSEC security policy enabled that blocked NetBIOS traffic.  Once it was turned off, bam, sharing worked again.  Thanks for all of the suggestions.  I'm going to split up the points between the answers.
aciadminAuthor Commented:
Didn't fix it but I appreciate the help trying.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.