Link to home
Create AccountLog in
Avatar of salinasman101
salinasman101

asked on

flash drive

I have a kingston flash drive, 64gig, datatraveler.  I plug the drive in and it sees it connected to the computer, the drive lights up, but when I go looking for it in My Computer it does not show.  Any ideas on how I can get the information on the flash drive.
Avatar of salinasman101
salinasman101

ASKER

What a day!
You can try going to Disk Manager see if the drive is there.
Avatar of Steven Carnahan
Does it show up in the "safely remove hardware"? If not then it isn't really being recognized.
How about using a different USB port?
Have you tried restarting the computer and after it is completely up plugging the device in again?
Can you see the flash drive on another computer?
Disk management, assign it a drive letter.
I can see the device in the "safely remove hardware", but after that I cannot see it or use it.  I have tried every USB port on my computer and I also tried 3 other computers and they are doing the same thing.  I also tried using the Disk Management and it does not show up there.  I have tried with two other computers besides mine on restarting them and then once they are completely up plugging it in and can only see the flash drive with "safely remove hardware."  

Any ideas what may be wrong?
In the safely remove hardware what does it say exactly? I just plugged my Kingston 4GB drive in and it shows me:  "Safely Remove USB Mass Storage Device - Drive (E:)" so when I look at My Computer I see a drive E:.  Has the drive been formated using something other than NTFS (guessing you are using a Windows system)?

Another thing to keep in mind is USB flash drives are restricted to drive letter G: and below so if you don't have one of those available this could be the issue.
Those high-capacity flash drives seem to have a very high failure rate (according to newegg.com user comments anyway).  I had a Corsair 32GB high-performance flash drive fail after a few weeks, where Windows Disk Manager could see *something* was there, but it could not do anything with it such as partition or format.  Anyway you could just have a bad one.
things to try :
-connect it on a powered usb hub
-use Safely remove to troubleshoot the problem  http://safelyremove.com/?pid=1
-try EZ recover : http://drivers.softpedia.com/get/Other-DRIVERS-TOOLS/Others/Sony-EzRecover.shtml                EZrecover

other tool  : http://www.snapfiles.com/download/dlsmartrecovery.html                  usb key recovery FREE
what operating system are you testing on..

maybe it needs drivers to work?
I am working both with windows XP and windows 7.  
I have now tried everything here, and that EZ recover thing, is it really worth purchasing?
does any one have any other ideas or suggestions?
ASKER CERTIFIED SOLUTION
Avatar of nobus
nobus
Flag of Belgium image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
you did not even look at the sites i suggested??
I tried the EZ recovery, the driver program, but was not sure about purchasing in, I have the safely remove program installed and tried trouble shooting, did not work.  I will try EZ recover and I missed the third one, I will try that also.
you have to admit that when you cannot access it on 3 different pc's - it can just be bad...
it can see the drive on the three computers, which makes it really weird, usually when they go bad you cannot see it anywhere.
As I said in my comment, I had one go bad where Windows could still *see* there was a flash drive present but couldn't do anything with it in Disk Manager or otherwise access anything on it.  The light on the flash drive was flashing rapidly too, probably indicating some kind of failure.
and that is why i suggested seveal testing/revoring softs
Another posibility, although the thread doesn't indicate anything to support it, is that the drive has been formated by a different OS such as Apple or AIX and therefore the file structure can not be read by Windows.  The problem with this theory is that you should still be able to "see" it in device manager.

I would tend to agree that the drive has probably failed.
I think the drive has failed, I tried the drive on my MAC and no luck, the drive is actually setup to run on either one.
then you have your answer
don't forget to close this Q