Link to home
Create AccountLog in
Avatar of HEC1152
HEC1152

asked on

Workgroup file shares not accessible

I'm having trouble accessing the file shares on WinXP (and Win7) machines.   These worked fine at one time but have recently stopped working for no apparent (to me) reason.   I have a WORKGROUP with several WinXP machines (w all service packs) connected sharing their drives/folders.   Firewalls are OFF on all XP machines.   I also have 2 Win7 machines in the same WORKGROUP, but my problem is more with the sharing with XP machines in WORKGROUP that had worked but now don't.   Here's the message I get when I select View Workgroup Computers on any of the XP machines:

"Workgroup" is not accessible.  You might not have permissions to use this network resource.  Contact administrator of this server to find out if you have access permissions.  Windows cannot find network path.  Verify that network path is correct and the destination computer is not busy or turned off.  If Windows still cannot find network path contact your network administrator.

Additional info is that all XP computers are ping'able my name and/or IP address from each other.   All shares can be accessed from Windows Explorer in form \\server\share.  All files on each XP machine have access set to Everyone with full control.  Simple file sharing is OFF on all XP machines.   All machines have administrator ID's that are the same on each machine.  Access to the machines is always via administrative account on any of the other machines.  

While not my primary issue, FWIW the Windows 7 machines have Homegroups and are visible to each other from Network.   Before whatever caused this problem, all the XP machines were also discoverable and listed in as connections to the Network.  All were accessible to Window 7.   Only 1 2 of the Windows 7 machine is "new" to the network.   Both of these machines are set to be part of WORKGROUP.   Access control is as open as I know how to make it to include 40/56 bit encryption enabled.   No firewalls are active.   And all of the XP machine shares are accessible by \\server\share and are pingable by name.

IP addresses are provided by standalone Linux DNS/DHCP server that has been stable for sometime.  This machine also has a number of shares but like the XP machines, this machine is not visibile on the network.  But it's shares are accessible from any machine by \\server\share.

I've tried all the usual (for me) tricks and have checked everything obvious, but I'd welcome any questions to confirm that I haven't missed something obvious.   The puzzeling thing about all this is that a week ago all was well in that everything was accessible from everything else by name.   Only the Win7 machine's shares weren't directly accessible from any of the XP machines but they were visible in the WORKGROUP.   ipconfigs from any machine look correct (i.e. correct IP of DHCP, DNS, and Gateway and correct WORKGROUP and netbios/hostname).   I have also tried releasing and renewiing all IP leases on every machine with no effect.   Turning off the Win7 machines does not affect the problem - i.e. the XP machines in the WORKGROUP are all alone but the local network remains inaccessible with the above message.

I think I've covered all the symptoms and state of the machines.    I'd appreciate whatever advise anyone could offer.
Avatar of netcmh
netcmh
Flag of United States of America image

I think I may have come across this. This is how I fixed it:

1. Click Start, click Run, type regedit in the Open box, and then click OK.
2. Locate and then double-click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
3. In the right pane, double-click restrictanonymous.
4. Make sure that the value in the Value data box is set to 0, and then click OK.
5. Close Registry Editor.
6. Restart the computer.
Avatar of HEC1152
HEC1152

ASKER

Do you mean that I should do this on all the WinXP machine's?
Avatar of HEC1152

ASKER

Just check on one of the WinXP machines.   It's already set to 0.   I've turned other XP machines off so that now there are only two on WORKGROUP along with the 2 Win7 machines.   Just wanted to make the process of looking at the suggestions like your easier.   All machines are supposedly confiigured the same insofar as network and WORKGROUP memebership/access goes, but this should make it easier to confirm that.   No effect on problem on having reduced size of WORKGROUP.   Thanks for the suggestion.
in the same path in the registry, is there a key named 'limitblankpassworduse'? Could you set it to 1?
Do you have simple file sharing disabled by any chance?
Do you have IPX/SPX/NetBIOS protocol installed on your network properties on your computers?
http://support.microsoft.com/default.aspx?scid=kb;en-us;301041 talks about adding NetBEUI to resolve issues like this
step by step for the IPX/SPX method:
1. Open Network Connections.
2. In Local Area Network, Right click on top of your connection and select Properties, click Install.
3. In Select Network Component Type, click Protocol, and then click Add.
4. Click NWLink IPX/SPX/NetBIOS Compatible Transport Protocol, click OK, and then click Close.
5. In Network Connections, on the Advanced menu (on top menu bar), click Advanced Settings.
6. On the Adapters and Bindings tab, under Connections, click the local area connection on which you are enabling IPX/SPX file and print sharing.
Under Bindings for Local Area Connection, under File and Printer Sharing for Microsoft Networks, clear the Internet Protocol (TCP/IP) check box, and then click OK.
sorry about the multiple posts, but the ideas aren't coming to me in an orderly fashion today.

Check the SERVER and the COMPUTER BROWSER service. Should be running
Avatar of HEC1152

ASKER

Well mixed results to report.  "initblankpassworduse" was already set to 1 on both XP machines.  THe SERVER and COMPUTER BROWSER services were running on both machines.   Simple file sharing is disabled on both machines (i.e. box not checked).  I haven't read the article yet, but I did install IPX/SPX on both machines per your instructions.   After that when I selected the local network where I had previously received the message I posted above, I could now a blank window on one of the machines (i.e. no workstation icons visible).  On the other XP machine, I could see both XP machines (the one I was on and the other one) as icons.   For the local machine I could view it's shares and access.  But for the other machine the following message was posted when I tried to view the contents of one of the shares:

"\\server\share" is not accessible.  You might not have permission to use this network resource.   Contact the administrator of this server to find out if you have access permissions.  Not enough server storage is available to process this command.

This is the mixed part of the results.   I'm not sure why the behavior of each machine would be different nor do I know why I would get the above error message since all the shares on both machines are set to permit Everyone with Full Control.

Also unlike before this problem with my sharing resources on WORKGROUP began, I cannot see either of the two WinXP machines in the Network list.   Only the two Win7 machines show.  Finally, I can no longer access the shares on either of the WinXP machines from one another using \\server\share.   Likewise, on the WIn7 machines, I can no longer access the network shares on the XP machines using \\server\share.  I was able to do this from any of the machines before I installed IPX/SPX.   I get the Permissions message.   So this represents a step backwards since not only can I not consistently see each WinXP machine's workstations from one another, but I can no longer access their shares.

While you contemplate this, I will read the article you referenced.
I'm stumped! :)

I have some time free later this afternoon and I'll try to get back to you. Other experts can and will chime in to try and get this resolved, I'm sure.
Avatar of HEC1152

ASKER

me too and now I can't get to any of my shares which makes this a much bigger problem for me.  Just FYI, hoping to perhaps get back to where I was before the IPX/SPX/Netbios install, I uninstalled everything that came with that on both XP machines.   Still no joy to include no access to the previously accessible shares via \\server\share reference.   Only errors in System Event log are for an irpstacksize which I've seen before a long time ago.   Turns out it's bogus as changing the value per instructions for that errorhas no effect on anything.  And as I recall from long time ago, this did not turn out to be the root cause of network sharing access problems.  Still it may be a clue.

I'd appreciate any help that anyone can offer. I've tried everything I can think of to include removing and adding each XP machine back to WORKGROUP with no effect.  Likewise releasing and reacquiring ip addrss from each machine has no effect.
Avatar of HEC1152

ASKER

More clues, perhaps.   I've noted that of the two XP machines, one is not ping'able (with the correct ip address) anymore from any of the Win7 machines.   This happens to be the XP machine that acts as file server and that has the most shares (which I could access before this original post).  I'm want to focus my attention on this particular XP machine to determine the problem because of it's function as a file server for the workgroup.  The result of trying to ping this machine by name from either of the Win7 machines is the return of an ip address that was associated with this machine sometime ago (before upgrading it to a 1Gb ethernet card).   Ping'ing from any WinXP or Win7 with the actual ip address that it has been assigned by the DNS server works but not so by it's name.   So, whatever the overall problem that's affecting share access, I think that by looking at this one XP machine, which is also a file server, may be the way to determine what the rest of the problem is.  

I should note that when I undid the IPX/SPX install, I also inadvertanty deleted the Windows Client from the connection.   After reinstalling it such that all appeared back to normal I had to recreate and reshare all the shares that previous (to start of this thread) had worked.   While doing this, I made sure that access to each of these was set to full control for Everyone and a user ID that was administrative and on each of the other XP machines.    

By focusing attention on this one XP machine to determin why it cannot see the workgroup nor be seen by any machine in the workgroup (XP or Win7) might be a way to work the rest of the problem.

I'd appreciate any advice anyone could offer.
Avatar of HEC1152

ASKER

Any suggestions or does this have everyone stumped?
Avatar of HEC1152

ASKER

Well since it would seem everyone is stumped or for some other reason ignoring this post I continued working on this over the past weekend.   Learned a lot and solved problem myself, I think.   Root cause seems to be issue with Master Browser which was somehow set incorrectly to the name of a USB device plugged into the WNDR3700 router.  Found that using BROWSTAT STATUS command.   Then powered off router after disconnecting/disabling USB drive connect (for NAS) feature.   Thought I had forced Browser selection to be on one of XP machines via using two items in registry  This was describes one of the parms (IsDomainMaster must be TRUE)

http://www.windowsnetworking.com/kbase/WindowsTips/WindowsNT/RegistryTips/Network/PreferredMasterBrowser.html 

But there's another one MaintainServerList in same place in registry (HKLM.System.CurrentControlSet.Services.Browser.Parameters).   This must be set to YES.   I don't know which of these did the trick since I still haven't been able to force selection of this machine to be Master Browser after powering cycling the router.  After that the selected machine per BROWSTAT STATUS was the Linux DNS/DHCP server which seems to do the job.   But, I would like to see if I can force the XP machine to be the Master.   Not sure how to tell the Linus machine to not volunteer for selection during Browser election but I know that if I power off a machine (e.g. the XP one), a Browser re-election should be forced among Windows machines anyway.   I'll keep looking into this but I wanted to at least post this if for no other reason than my own future reference.
ASKER CERTIFIED SOLUTION
Avatar of ee_auto
ee_auto

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account