Link to home
Create AccountLog in
Avatar of marshalll
marshalllFlag for Canada

asked on

Problems opening a Visual Studio Solution File

I am having troubles opening valid sln files that my co-workers have no problems accessing.  

Through Windows Explorer, nothing happens when I double click on a *.sln file.  When I try to open the solution file using SQL Server Business Intelligence Development Studio I get an error box that says "The selected file is not a valid solution file."

This may be related to how the programs were originally installed on my workstation.  Originally, all I had installed on my workstation was SQL Server 2005 Management Studio Express Edition.  A few months later, I was given an MSDN license and I was asked to install both SQL Server 2005 Developer Edition and Visual Studio 2005 Professional.  

I did not know that order was important during the installation process so I installed Visual Studio first and then SQL Server.  When I found that the SQL Server Management Studio Express Edition was still installed, I realized my mistake and I reinstalled SQL Server with the option to force the full SQL Server Management Studio to be installed.

I never tested my ability to open sln files prior to the reinstall of SQL Server 2005 so I don't know where or when the problem crept in.  The program associated with sln files is "Microsoft Visual Studio Version Selector".  I have tried uninstalling and reinstalling Visual Studio but I still have the same behaviour.

Short of a full rebuild does anyone have any suggestion on how to resolve this issue?

SOLUTION
Avatar of EYoung
EYoung
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of marshalll

ASKER

EYoung, thanks for the response.

1. Yes, we are running the same version. When I reinstalled, I made sure that I ran Microsoft update to get VS2005 patched up to the latest service pack.
.
2. Yes. We are accessing the sln files on a network file server.  I have tried using both a mapped drive and the full network path but the same thing happens.

3. Yes I have tried using VS2005 to open the file but I get the same error that it is not a valid solution file.

In addition, I have tried creating an Integration Service Project locally and it always results in an error "Exception from HRESULT: 0xc001100E".  The project directory gets created but the sln file is not there.  If I try to create another project type like "Report Model", it is created without issue and the sln file is created and I can open the sln file through windows explorer and VS2005.



I can't think of anything else to try.  It sounds like there is something different about your computer hardware or OS.  The next step is to rebuild the solution.  Best of luck with that.
Avatar of kaufmed
What kind of solution is it? You started off by saying you were working in BIDS and then changed to saying VS. Although they look the same, the are not.
I am talking about the VS solution file with the extension of .sln.  I never said I was working in BIDS.  
And I'm speaking to the author. I never said you were working in BIDS either  ;)
Oops.  Sorry.  I misread the blog.  Yes, I was confused about the author's comments also.

Marshall - This link might help.  It helped me.  See entry for April 17, 2009.
http://social.msdn.microsoft.com/forums/fr-FR/vbide/thread/52bc04f9-f086-4adf-ac17-b0ea9f433c39
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I ended up figuring out the solutions to my issues on my own.

I awarded partial points to to EYoung because he tried to give some items for me to check in my investigation of the problem.