Link to home
Create AccountLog in
Avatar of ITEngineering
ITEngineering

asked on

NetWare Application association does not show all users/groups associated

I've discovered that many of our NAL app objects do not show any associations, but some groups/users do show an association with that app.
For example:
AppObject1 shows no associations for it.
Group1, Group2, and Group3 show an association with AppObject1.
Avatar of ShineOn
ShineOn
Flag of United States of America image

What version of ZENworks?

Can you take some screen shots and post them, or something?
As far as i can tell associations are administered in both the application and the group / user / OU objects.

When an application is associated with a user or group or OU that user (or group etc.) gets an appAssociations entry, and the application object gets an ACL for that user (or group etc). It is the responsibility for the tool that you display eDirectory data with (ConsoleOne? Nwadmin?) to read the application ACL list and get from the user object the type of association (ForceRun, AppLauncher, StartMenu etc)

You can use a tool like Softerra's LDAP browser to check if the correct ACL's have been set on your applications, and to see if the correct appAssociations are set in your user / group objects.

http://www.ldapadministrator.com/download.htm

Could you also post the version of ConsoleOne and eDirectory
ASKER CERTIFIED SOLUTION
Avatar of ShineOn
ShineOn
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of ITEngineering
ITEngineering

ASKER

Novell Netware, V6.5 Support Pack 6
Using NWAdmin
Most App objects show the associations, but several do not.
We're a little leery of running a DSRepair (Yes, I know it should be done more often) because it hasn't been run in a long time. We're trying to get rid of NetWare and were hoping to get by without running one. I can export the users/groups and their associations, so I can cross reference against that. Just a little more time consuming.
I've attached screenshots of one of the problem apps. One shows the app and no associations, the other shows a group and it has the association listed for the app in the first pic. User generated image User generated image
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Zen is 3.0
NWAdmin is old, but it's still the 'best' tool to manage most things in NDS.
Console One does list the users/groups as trustees but I can't modify anything on the app objects.
So I guess a DSRepair is the only way to get them back in NWAdmin. Since the associations are listed on the app object and on the users/groups I don't need to worry too much. It's just a visibility issue. I just need to accelerate the removal on NetWare from our environment.
Um.   I suggested a dsrepair may be in order back in my comment 34464672.

Fearing running dsrepair is like fearing rebooting Windows once a month. It's a misplaced fear.
For Zen 3 to be able to be managed with consoleOne you need the Zen 3 snapins for ConsoleOne:

http://download.novell.com/Download?buildid=TzO_87kg_kA~

The NwAdmin snapins for Zen only work correct for Zen 2 and Zen starter
Split points 34470334 and 34464672

Dsrepair in combination with using the proper administrative tools should fix this.
All,
 
Following an 'Objection' by ShineOn (at https://www.experts-exchange.com/questions/26718870/12-Jan-11-08-Automated-Request-for-Review-Objection-to-Accept-Q-26707377.html) to the intended closure of this question, it has been reviewed by at least one Moderator and is being closed as recommended by the Expert.
 
At this point I am going to re-start the auto-close procedure.
 
Thank you,
 
SouthMod
Community Support Moderator