Link to home
Create AccountLog in
Avatar of STS-Tech
STS-TechFlag for United States of America

asked on

Windows Vista failed ZoneAlarm Removal

I have a friends PC that will not go on the Internet.  He told me it began after he uninstalled ZoneAlarm.  It does not detect a network cable being plugged in.  It can see wireless networks but cannot connect to them.  I have uninstalled and reinstalled both NICs and ran the Winsock IP fix program to no avail.  I have also tried the ZoneAlarm removal tool but it fails to launch.
Avatar of 10023
10023

Check if Zone Alarm assigned a proxy server to Internet Explorer
Go to [internet options] in IE
then [connections]
then [lan settings]
then uncheck [proxy server] if it is checked
shut down restart ie and check for connection
Avatar of STS-Tech

ASKER

No, no proxy in place. Also tried Firefox and could not connect.
Use System Restore and restore behind Zone Alarm install
go to programs/accesories/system tools/ and system restore and follow prompts
No system restore point that far back. More info - IP config shows no info.
If no adapters seen with ipconfig /all
then make sure adapters are not disabled in Bios
use proprietory key sequence during bootup
Avatar of John Griffith
Try Safemode w/ Networking - tap F8 key repeatedly during boot.
Both adaptors enabled in BIOS and visible both in Device Manager and Network Center.  Safe Mode produces the same result.  Also, TCP v4 and v6 are available and bound in properties of both NICs.  Its as though the PC "forgot" how to do TCP, but I can't find a way to remove and reinstall.  Tried reinstalling SP2 but it tells me "already installed" and I can't find a method of removal.
Why did Zone Alarm get removed to begin with?   Was it because he could not access the internet? If that is the case then Zone Alarm is a red herring.  

Have you tried resetting the computers bios to factory defaults and rebooting/resetting the router it is connecting to.  
His adapter does not detect the cable being plugged in.  Is the cable bad?  Is the NIC bad?  I am not going to ask if the cables are plugged in....;p okay I did but I don't want to.
If it still thinks the can not detect a cable being plugged in then maybe the router is bad or maybe the port on the router is bad.  Try a different port.
I'll ask why it was removed, but he did say it was working before the removal.  I did check the BIOS but didn't reset anything, I'll give it a try.  As for the physical connection issues, I'm testing on my equipment- all tested and known good.  Remember- it actually sees and connects to the Wireless, just never picks up an IP.  
Okay and if you set a static IP address does it work?
Good idea- Don't have the laptop with me right now, but I will try that as well tonight.  I've seen this before with an XP machine and there was (if memory serves me) a registry entry pointing at an invalid DLL but I've searched the Reg for anything named ZoneAlarm and removed everthing I could find.
No luck with resetting BIOS, Safe-Mode, or Hard-Coding.  Still nothing returned from ipconfig /all except Host Name, Prim DNS Suffix, and such- but no IP, SM, GW or DNS.
Is  the OS 64 bit ................if so
here is a link for a removal tool off of Zonealarms site
 ... hope it helps
http://download.zonealarm.com/bin/free/support/cpes_clean.exe
They said to reboot before running but after download ?   I don't know why
Nope, 32 bit.  I already tried cpes_clean but it doesn't run (even if I do a reboot).  It just gives me the "wait" icon for a few seconds and then nothing.  Even tried it in Safe-Mode.  
Did you run Z/A removal tool as admin?

RIGHT-click, "Run as Administrator".

If no-go, reinstall Zone Alarm, then uninstall it - try Revo free - http://www.revouninstaller.com/revo_uninstaller_free_download.html
I did.  I also tried reinstalling ZA to see if it would start working again but the install failed.  This thing is totally messed up!  I will try Revo.
Then the problem is most likelty in the network sharing.  Making the network you can not attach to a home network?  I am not sure.  If it were only one NIC I would say bad NIC. Because you say it is the RJ-45 and the wireless I have to think either  in the Network Sharing or a bad motherboard. Who makes thie machine?
It's a Sony Vaio.  I agree with your statement.  It seems as though there is something wrong with the TCP-IP configuration.  If only there were some way to completely remove and reinstall.  As I mentioned before- I think I fixed this in the past by changeing a Registry setting that pointed to a deleted ZoneAlarm dll.  You had to change the setting back to the windows dll.  Sadly- I've not been able to track down the article.  I really want to figure this one out- not only cuz I don't want to have to rebuild it, but also just to know for future reference!
You can do a repair on the OS with the Vaio?  I can with XP and Vista if I have the CD but I don't know if you can do that iwth the VAIO as I don't know what it comes wtih.  Does it have a recovery CD that only does the OS and does not destroy all the hard drive info?  I would try that next if it were an option.  Then put the nics in other machines to see if they work there.
I hate to keep saying "yeah, tried that" :)  but yes- I booted to a Vista disk (not the one that came with the PC but it worked) unfortunatly the only options were to apply a fix if your PC isn't booting, use a restore point, or use a full backup.  None of those options helped me.
You might be able to complete a partial uninstall of Zone Alarm using AppRemover:

http://www.appremover.com/

Are there any other av products installed? A HJT log might help to see what is going on:

http://free.antivirus.com/hijackthis/

Post a scan log here for review.
ASKER CERTIFIED SOLUTION
Avatar of STS-Tech
STS-Tech
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Not solved- rebuild was completed