Link to home
Create AccountLog in
Avatar of aparsons98
aparsons98

asked on

Home Directory permissions

I am just setting up a new AD server and had a brain fart while making the home directory share.

My setup is a Windows 2008 R2 Server, AD is setup and working. I created a share of Homes$ then set the permissions to “Everyone” = Read, “Admins”= Full. It creates the home directory when I create the user so that’s good. When I try to login I have no access to the share. I really do not remember anything more I had to do in 2003 to get these to work. If I give everyone full control it works but I do not want other users to have access to other home folders.

Now it’s a new server so I have no problems on making a new share since I only have 2 users on this so far. I just want to make sure everything is correct before I add the 600 users to it.

If someone could give me step by step that would be awesome. I have been in the Mac server world for about 3 years so I have forgotten all my Microsoft stuff.
Avatar of Mike Kline
Mike Kline
Flag of United States of America image

What are the NTFS permissions on the folders?

Thanks

Mike
See if this helps


How to dynamically create security-enhanced redirected folders by using folder redirection in Windows 2000 and in Windows Server 2003

http://support.microsoft.com/kb/274443
ASKER CERTIFIED SOLUTION
Avatar of kevinhsieh
kevinhsieh
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I have found that users need to have FULL control over their directories for things like folder redirection to work properly. I would rather give them modify, but it hasn't worked for me.
Avatar of aparsons98
aparsons98

ASKER

I figured it out this morning, it was the inherit box was chked in the advanced permissions. The DFS looks awesome, i havent messed with that yet. Maybe ill try it out.