no server connection, you are not connected to a server

I get this error when starting sql server 2005 enterprise management studio

I am using windows server 2008.

this was working before, and then I restarted windows

the connect button is greyed out
I try
windows connection
sql server connection
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


 Go to Start > Programs > Microsoft SQL Server 2005 > SQL Server Management Studio
Right-click the Server name, select Properties > Security
Under Server Authentication, select SQL Server and Windows Authentication Mode
The server must be stopped and re-started before this will take effect..."

Hope it will helpful to you

rgb192Author Commented:
i cant right click server name
because I can not connect to a server so there are no servers/databases listed
my problem is one step before that
Norman MainaCommented:
Go to services >START>RUN>services.msc

And then Start the SQL Server services
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

rgb192Author Commented:
all sql server services
are started automatically and running
except for
sql server active directory helper

sql server is working because I am connecting through php
I can not connect through sql server mangement studio enterprise
Norman MainaCommented:
Is the management Studio you are trying to access local or in a network pc?
Norman MainaCommented:
you can check on:
1.Are the sql server protocols enabled?check on TCP/IP and Shared memory
2.Is your anti virus blocking ssms?
3.When you disconnect from accessing teh database using  PHP -are you able to connect using ssms?

rgb192Author Commented:
I am attempting to connect on ssmse using local pc
it was working before I did windows update and restart computer
I am attempting to connect using windows connection or sql server connection

anything I type in
the connect button is greyed out
Norman MainaCommented:
looks like windows update messed up your ssms.
try re-installing it.(un-install first)
Do not uninstall the database - just uninstall ssms.

If you are unconfortable doing that - try installing the latest service packs of your sql server version and see if it fixes the prblem for you.
rgb192Author Commented:
how to uninstall/install just ssms

i am using sp3  is this the latest sevice pack
Norman MainaCommented:
rgb192:>i forgot to tell you that you can try to repair the installation first before you un-install.Use the SQL Server CD and run setup -like a normal install but you select repair.

re-install/repair without uninstall:

To un-install -follow these steps:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rgb192Author Commented:
TITLE: Microsoft SQL Server Setup

None of the selected features can be installed or upgraded. Setup cannot proceed since no effective change is being made to the machine. To continue, click Back and then select features to install. To exit SQL Server Setup, click Cancel.

For help, click:


rgb192Author Commented:
the un-install works
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.