Link to home
Start Free TrialLog in
Avatar of smeek
smeekFlag for United States of America

asked on

Can't upgrade Vmware Tools from within a VM after upgrade to 4.1

It is probably an easy issue but I can't figure out.  We upgraded our hosts from 4.0 to 4.1.  After the upgrade, I see the standard hint in the system tray that the new version of the tools are available and I can upgrade.  I right-click to open tool like I have done in the past and run the UPGRADE button, but nothing happens.  

Anyone else run into this issue that can point the way?
Vmware-tools.jpg
Avatar of Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Flag of United Kingdom of Great Britain and Northern Ireland image

The only issue I've noticed, is when using ESXi (embedded) on a SD/USB stick, it takes about 5 minutes for the tools setup program to appear. But I think this is to do with speed of access mounting the iso on the SD cards.
If you select the VM and Select VMware Tools (upgrade) from there, what happens, do you see any tasks start in the events in VC?
Avatar of smeek

ASKER

When I hit the UPGRADE button, the tools window disappears.

S
I've got some 2003 Servers VMs, on a ESX 4.0 - ESX 4.1 host, where I've not upgraded tools, yet, I'll try now.
Interesting observation, when I select the VMware Tools in system tray, and select Upgrade Tools, nothing appears in the Events Windows, but when I select the Guest VM, when I select Guest, Install/Upgrade Tools, it stated End Tools Install

It's as if, it's doing a silent Install from the Smart Tray tool... and then Restarts the Server (whoops!)



Avatar of smeek

ASKER

I've also tried from vSphere client to my vCenter server and selecting the guest menu, I can see  a task that Installer initiated and show as completed but no other tasks after that.
So it works for me silently.....won't be doing that again!

it gave no warning, of a server restart!
try a manual one, and see if it works, maybe the installer is failing.

check event logs and \temp directory for installer logs.
going to have to explain a server restart in the middle of the day now, without scheduled downtime!

Whoops!
I did the same thing last month, hanccocka.  

I've seen a couple of upgrades on 2008 not need a reboot, but safest thing to do during production hours is to start an interactive upgrade from the vsphere client and then watch it install through the console.

smeek, like hanccocka said, does any other method work?  I've seen instances where the .iso didn't get copied over during the upgrade or it got corrupted.
Avatar of smeek

ASKER

I'm thinking it might be some issue with access to the tools.  Suggestions on how to correct that?

hanccocka, thanks for crashing your network for me.  Maybe you can ask for a mulligan since it near last day of the year.
@danm66: I don't normally do Tools Upgrades from the Smart Tray Tools, I usually do Interactive ones!

but I didn't expect ti Shutdown and Restart without prompting!

Just trying to helpout and Expert Exchange User, I'll now next time!!!! (not to pick any machined, I'm RDP-ed into!)

he he!
checkout c:\windows\temp\vminst.log for why installer failed.
Avatar of smeek

ASKER

Last entry was 8/19.  I deleted log and reran and file was not recreated.  
or whatever your %Systemroot% is.

ssh onto the server, and check /vimages/tools-isoimages

should see a list similar to following (i'm ESXi (embedded) 4.1)

-rwx------    1 root     root           13817856 Oct 10 21:51 freebsd.iso
-rwx------    1 root     root                256 Oct 10 21:54 freebsd.iso.sig
-rwx------    1 root     root           48588800 Oct 10 21:54 linux.iso
-rwx------    1 root     root                256 Oct 10 21:55 linux.iso.sig
-rwx------    1 root     root             540672 Oct 10 21:51 netware.iso
-rwx------    1 root     root                256 Oct 10 21:54 netware.iso.sig
-rwx------    1 root     root            9500672 Oct 10 21:52 solaris.iso
-rwx------    1 root     root                256 Oct 10 21:54 solaris.iso.sig
-rwx------    1 root     root                451 Oct 10 21:55 tools-key.pub
-rwx------    1 root     root           13467648 Oct 10 21:52 winPre2k.iso
-rwx------    1 root     root                256 Oct 10 21:54 winPre2k.iso.sig
-rwx------    1 root     root           50790400 Oct 10 21:52 windows.iso
-rwx------    1 root     root                256 Oct 10 21:54 windows.iso.sig
@hanccocka my comment about interactive wasn't directed at you...just a general comment for the readers to consider.

@smeek if you initiate it from the vsphere client, do you see it mount the .ISO to the cdrom drive within the VM?
@danm66: I don't mind the reminder!!!! no offence taken!

 ;-)
Avatar of eeeznutz
eeeznutz

For what it's worth, I always use Update Manager for my VMware Tools upgrades and I always do it off-hours since it can often impact the network driver. That said, VMware really changed how VMware Tools installs are done in 4.1 for Linux VMs, but this thread is related to Windows so I'll stay on topic. Look into Update Manager. It's particularly helpful for the VM HW upgrade as well as the VMware Tools upgrade...especially when both need to be done.
Hi

Try to remove the VMware Tools first. Then do a manual install of the new VMware tools. Do not use automatic upgrades.

Just mount the VMware tools on the CD/DVD drive and click on it to install.

This type of issue happen some times when we do a vSphere upgrade.

Jail
you should unblock ESXi following this steps:

http://www.vm-aware.com/2008/07/enable-ssh-for-esxi/

and, in "removable devices", mount a cd drive at startup, then run vmwaretools installation/upgrade.


Those two things solved my exact same problem
@Guillermin-go: no need to "unblock" ESXi this way anymore, you just go to Security Profile and Select Remote Tech Support - Start!

and then SSH acccess is done.
ASKER CERTIFIED SOLUTION
Avatar of smeek
smeek
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of smeek

ASKER

Thanks to everyone for their input.  I learned more in just hearing other peoples thinking processes and ways of thinking.
Avatar of smeek

ASKER

This is what fixed issue.