Link to home
Create AccountLog in
Avatar of tchancev
tchancevFlag for United States of America

asked on

Realtek 8187 Wireless Device Install Trouble with Windows Vista SP1 & SP2

New install of Windows Vista SP2 on a Gateway M-1631U laptop.
All drivers install fine except the Realtek 8187b Wireless Adapter.
Have tried all downloads offered via Gateway support site and Realtek as well.
Vista reports software for device is found but that installation is not successful because device will not start.

This WiFi device was working prior to the reinstallation of Vista due to virus issues.

Typically going directly to manufacturer site the proper drivers can be located.
Not this time.

Anybody got any ideas?
Avatar of sfossupport
sfossupport
Flag of United States of America image

Did you run updates and install dot net. This needs to be done before installing the drivers

Starting to become a requirement for wireless and some graphics cards.
Avatar of tchancev

ASKER

dot net 2.0 already installed with Vista.
dot net 3.0 reports not meant for Vista?
dot net 4.0 installed.

As far as updates go, the latest service pack installed is SP2, and I am fairly confident that SP includes all the most critical patches and updates.  Unless a box will not boot otherwise, I tend to stay away from windows updates since they cause just as many problems as they fix in my opinion.

Are you familiar with a specific windows update that this Realtek device would need?

During device software installation, Cisco 802.1x Module for Vista also installs.
Then the infamous "reboot now to complete installation..."
Then reboot, and Realtek Wireless LAN Manager app is accessible but reports no Realtek 8187 Wireless device is found.

Device Manager lists this currently as Network Controller.
When I manually force the driver installation, device manager lists it properly, but that is where the first part of this thread begins.....Unable to complete installation because device is found but wont start.
Went ahead and installed ALL dot net service packs from windows update and still same result....
The first thing to do is make sure you are trying to install the correct driver. If you post the device instance ID, we can check that for you.
Right click on the device and select properties.
Then select the "Details" tab
Use Ctrl+c to copy the device instance ID string.
Then paste it (Ctrl+v) in your reply.
Realtek driver downloads - RTL8187b -

http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=1&PFid=1&Level=6&Conn=5&DownTypeID=3&GetDown=false&Downloads=true#1431

Also try uninstalling ALL devices found under Networking in Device Manager -
START | devmgmt.msc

Vista will reinstall upon reboot.

Happy New Year !

jcgriff2

nobus & icgriff2:
In the first post on this question, I mentioned that we already downloaded ALL possible drivers from Realtek and Gateway so sending us back to Realtek is of little help.  Both your links are identical in that hit the exact same Realtek download site.  But thank you, anyway.

edbedb:
I determined that this is a Realtek 8187b wireless adapter using the device instance ID myself.  But in an interest of being thorough, the dev ID is: PCI\VEN_14E4&DEV_1659&SUBSYS_3260103C&REV_11/4&186DEF45&0&00E5
If you can glean more information about it. that would be great.

Is this 32 or 64 bit ?. You may need to edit the net8187.inf. Check the id for vista.

I think you gave me the wrong ID. PCI\VEN_14E4&DEV_1659&SUBSYS_3260103C&REV_11/4&186DEF45&0&00E5
 is for a Broadcom NetXtreme Gigabit Ethernet PCI Express
edbedb:
Yep, I submitted that ID from another project I am working on. My mistake.  :0)
Here are the correct dev IDs:
PCI\VEN_10EC&DEV_8199&SUBSYS_819910EC&REV_22&REV_22
PCI\VEN_10EC&DEV_8199&SUBSYS_819910EC
PCI\VEN_10EC&DEV_8199&CC_028000
PCI\VEN_10EC&DEV_8199&CC_0280
ASKER CERTIFIED SOLUTION
Avatar of edbedb
edbedb
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
you can also try drivereasy (free) from          www.drivereasy.com
edbedb:
I knew it was the Realtek 8187 but obviously the model number was slightly different.
Your help provided me the download we needed.
Thank you very much.

To all others that offered assistance, I thank you as well.