Link to home
Create AccountLog in
Avatar of Khate
KhateFlag for Singapore

asked on

Customised web part causing Access Denied to users

We have a room booking subsite and we purchase the template from room manager. Suddenly the confirmation email is not being sent, after doing some troubleshooting we also checked the webparts available on this room booking page. One of the web part is the CheckConflict, we toggled the value for the SendEmail from Yes to No then back to Yes. After doing this, users are getting Access Denied.
 User generated image  User generated image
So whenever we remove this webpart, users are able to access the site and but theyre not being prompted anymore if there's a conflict on the booking. We have 2 issues now, the webpart thats causing the access denied and the alert but help us with the webpart first please,thanks
Avatar of Khate
Khate
Flag of Singapore image

ASKER

I have created a test site where I used the same room booking template to test if we can fix the issues there. The email alert is working fine there now, we found out that the w3wp.exe was being block by McAfee and checkconflict is also working on this test site.

But for the live site, still the same. I still cant put back the checkconflict webpart as its still causing the access denied. to this site. The Domain users and authenticated users have contribute permission to this site.

Is this a corrupted we part?
Make sure that:
1. on your site collection/_catalogs/wp/Forms/AllItems.aspx: the permissions are kept inherited.
2. also try after removing audience targetting if you have for this wb, to me it is a 3rd class feature--moss 2007.
nothing works, better try re-upload wb and
also try togling value for the SendEmail yes no, may work.

for alert part please elaborate issue
Avatar of Khate

ASKER

Hi MineSharepoint,

Thanks for the reply. Sorry I'm new to sharepoint just few months ago.

1. on your site collection/_catalogs/wp/Forms/AllItems.aspx: the permissions are kept inherited->>yes I believe the setting for this still inherited.

2. also try after removing audience targetting if you have for this wb, to me it is a 3rd class feature--moss 2007.
nothing works, better try re-upload wb and ->>> Im not sure how to do this and what's a wb. But I have tried toggling the Yes to No and back to yes and reload that web part but still users will get access denied.


is it moss 2007.. & which auth type are you using also inform user is coming from internet or intranet & though domain id or not...
ASKER CERTIFIED SOLUTION
Avatar of Khate
Khate
Flag of Singapore image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.