Link to home
Create AccountLog in
Avatar of northernknight
northernknightFlag for United States of America

asked on

USB keyboard and mouse not working in Windows XP

I am working on a customer's computer that once it is booted to Windows XP, the USB mouse and keyboard do not work.  The computer does not have a PS2 port to try that type of mouse.

I tried booting from an XP Pro disk and it loads the drivers and then says "starting Windows" and then goes to the BSOD.

If I just let the machine boot to Windows I don't get the BSOD.

I tried resetting the BIOS to default (the keyboard works in the BIOS) but has no affect.

I also tried cloning the drive to another new drive and get the same.

Avatar of ShaulMarcus
Flag of Israel image

Did you try loading into safe mode?
Avatar of ramasamy_rams

having the same issue
Since booting from an XP Pro disk gives you BSOD, then you may have faulty hardware, so I would suggest that you check RAM memory and/or CD/DVD drive.

I had a similar "USB not working" issue recently, and solved it by "Windows repair" which is booting from an XP Pro disk, choosing "install Windows" and then "R" for "Repair Windows installation" (option which you get when choosing where to install Windows).
Ensure that legacy USB devices or something similar is enabled in bios.

Chris B
Might be the power adapter not getting enough power to the usb devices. Good thing would be to replace it with another one and check then. Also did you try ONLY the keyboard or only the mouse ?
After Windows has started, what happens if you unplug the keyboard and mouse then plug them back in?

Can you tell if other USB devices are working? Try attaching a USB flash drive or something.

-> USB Mouse works on Safe mode ?
If 'yes' , than ignore below advice.

-> Set BIOS setting to Factory Default,Save & Exit
-> If you could manage to download latest BIOS update and install on normal mode without mouse support, you should (Recommended)

Regarding -> I tried booting from an XP Pro disk and it loads the drivers and then says "starting Windows" and then goes to the BSOD.

Possiable cause could be :
1st -> SATA drivers may cause this BSOD as well.
           if your BIOS offers a setting to run your SATA drive in "IDE mode" or "Compatibility mode" instead of "AHCPI    mode try changing to IDE or Compatibility mode and try installing xp.

2nd -> One the Memory Stick could be faulty, If more than one memory stick, Test Each Memory stick independently (Try booting with xp pro cd and try installing on each memory Stick)

More details of system may help ( Desktop PC ? , Total Memory?  Hard drive is SATA or IDE ? )
Avatar of northernknight


MORE INFO:  The Computer is a Dell Desktop XPS 410.  It has 4 sticks of ram, two of them are 500mb, the other two don't say.  

I get the same thing in safe mode, no mouse or keyboard and can't get past the choose user screen.  the hard drive and cd rom are SATA.  I have tried unplugging the CD and boot to Windows and still cannot use the mouse.  I also tried mouse only and unplugged both and plugged them back in while in Windows.  It seems that while in Windows, it trys to install device drivers for different hardware that I install (mouse, keyboard, hard drive) but I cannot click the message that says to continue anyway.  It also has other error boxes when windows boots but I cannot click on anything to try to fix it.  I would definitely do a repair install if I could get my disk to work.  I tried two different XP disks with the same result.

I don't see a setting in bios to run in IDE mode.  I did try the RAID options and it doesn't help.

I tried resseting the bios and also checked the settings for the USB.  All USB ports are on in the bios.  I also tried turning them all off and then back on.  The USB keyboard works in the bios, so obviously the ports work.  Its just in Windows.

I am thinking about formatting a fresh hard drive without the OS and trying the XP disk.  I have also tried just using one stick of ram, but I only checked one so far.
I think that the key here is that Windows is prompting you to allow it to install the drivers for the keyboard and mouse.  Of course, since the mouse and keyboard are not working yet, you can't click on the prompt to proceed.

I had this on a client's computer once and was only able to resolve it by using his keyboard or mouse.  Once that was connected I was able to use my mouse and keyboard, using his to click through the installation.  I never came up with a better solution.

Have you tried a variety of keyboards and mice, the more generic the better?

Another trick would be to find out how to enable Remote Desktop by editing the registry.  If you can boot Bart PE or UBCD (I'm assuming that the mouse and keyboard will work there; probably a good test) and do such an edit, you can reboot the computer and try to get in through Remote Desktop.  From there you can accept the prompts to install the keyboard and mouse.
I am pretty sure that the XPS 410 does have an option to set the SATA controller to IDE mode.

I am doing this from memory so you might have to use your imagination.
In the BIOS select Storage maybe? In any case you are looking for the SATA options.
The last setting in the SATA options is the one you want to change. It may not say IDE, it could be called Compatible, ATA or something else. It is not RAID and I don't think it is AHCI? either.
After doing that you should be able to boot your XP install disk.
Hey edbedb, all it has for the sata is off and on.  It also has the choice of raid autodetect/ata or raid on.  I tried those options.
I found someone with the BSOD problem and may need to load the raid drivers when booting from the CD since the possibly the XP disk doen't include the raid driver.  Here's the post, 
Avatar of edbedb
Flag of United States of America image

Link to home
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Once I created a slipstream boot cd using Nlite from my install disk and added the sata and raid drivers, the computer can boot to the new cd.  I am trying the repair install which is what I set out to do in the first place.