Link to home
Create AccountLog in
Avatar of master_windu
master_windu

asked on

Unable to mount NFS share after ESXi 4.1 upgrade

m having a problem adding nfs storage to esxi 4.1 from vsphere client.

previous to 4.1 upgrade there was no issue.

here is what im inputtings

ip 192.168.1.4

folder /VMWare

error:

Call "HostDatastoreSystem.CreateNASDatastore" for object "ha-datastoresystem" on ESXi "192.168.1.5" failed.

Operation failed, diagnistics report: Unable to complete Sysinfo operation. Please see the VMkernel log file for more details.

my esxi host is at 192.168.1.5

I dont know how to view the vmkernal log referenced

NAS is WD Worldbook

I have checked on case of share name as well

Thanks
Avatar of Paul Solovyovsky
Paul Solovyovsky
Flag of United States of America image

ensure that you can ping the the NFS host via vmkping command to ensure that it's not a network issue
Avatar of master_windu
master_windu

ASKER

i am able to ping my NAS device (192.168.1.4) from the ESXi host
check the logs on the WD drive if it has any.  Since the device is not on the VMWare HCL it may not work with the new version.
that sucks if its not compatible seeing how it worked fine with ESXi ver 4.0

no logs seen on NAS to indicate what issue is

i think ill just move over to xenserver since it seems like their free version has more features
if you cannot ping the WD Worldbook NAS from the ESXi host, this could be an issue.
ASKER CERTIFIED SOLUTION
Avatar of Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
here's the NFS (WD Worldbook) added to an ESXi 4.1 host.

 User generated image
don't believe everything on the HCL, it just means that VMware have not tested it.

and therefore, you might find it difficult obtaining a support from the VMware channels.

We've got loads of x-production kit, that worked with ESX 1.0, 2.0, 2.5, 3.0, 3.5, 4.0 that works with ESX 4.1.

Network cards, Servers, HBAs, SANs etc

It's not supported by VMware, but then again there's some hardware on the HCL, that doesn't work with 4.1 either! (but that's another question!)
yes, simply adding /nfs fixed my issue.  Thanks!