Link to home
Create AccountLog in
Avatar of jddebug
jddebugFlag for United States of America

asked on

What settings do I use to email logs and alerts from Sonicwall NSA240 using gmail?

I had this working a number of months ago and then wiped my settings and can not figure it out again.

I'm trying to get the settings right to email the logs and alerts using gmail. I am getting an error in my logs saying "Warning      Firewall Logging      Problem sending log email; check log settings".

Log/Automation

Send Alerts to E-mail Address: (my gmail address)

Mail Server Settings

Mail Server (name or IP address): smtp.gmail.com
From Email Address  (My gmail email address)
Authentication Method: None

In advanced settings next to the mail server settings I have Port set to 465 (had it at 25 before and didn't seem to work either), Enable SMTP Authentication checked, My gmail username (The part before the @ symbol in my email address) entered along with my gmail password.

Seems I can't get the right combination of settings to get it to work.

Thanks.
Avatar of als315
als315
Flag of Russian Federation image

Normally you can't send mail with same values in From and To fields. Try to set different from Gmail account in field From. (It is better to use real address, but you can try myfirewall@sonicwall.com, for example). You will not need authentification.
Avatar of jddebug

ASKER

Ok, sending it to my hotmail account for now but still not working. Reading at gmail's webhelp I found that I need to have the username in the form username@gmail.com but that did not fix the problem and I get the same error in the logs. I tried disabling authentication and that has not worked either.

I do see that they want SSL or TLS. I have chosen the correct port for SSL but I do not see an option for SSL or TSL. Very odd that a secure firewall would send its logs/username password out over an unencrypted connection.

Still needing help on this one. It has worked before. A few months back. What am I missing here?
SOLUTION
Avatar of als315
als315
Flag of Russian Federation image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
You are on right way.
SMTP for incoming mail to gmail accounts is:
gmail-smtp-in.l.google.com
(you can check it with any of free DNS checking tools,
http://www.checkdns.net/quickcheck.aspx?domain=gmail.com&detailed=1
for example)
smtp.gmail.com is used for sending mail from gmail accounts.
Avatar of jddebug

ASKER

Ok, I don't get it. Is it related to the way the firewall is sending out the email? I think it requires the next email server to be a relay.

At first I had my settings just like my email program does for gmail. (smtp.gmail.com) I do not see the difference but it must be that the firewall is like a mini email server and my email program is just a client?

The difference is the following:
smtp.gmail.com needs authorization (you can use your account data and it should work)
gmail-smtp-in.l.google.com is smtp server for incoming mail, it does not need authorization, but you can send mail only to google accounts (otherway it will be open relay server).
I think it requires the next email server to be a relay.
May be, in this case you had to use one of your accounts (with authorization).
Avatar of jddebug

ASKER

Well, get this, it has stopped working again. and I have not changed anything. I'm going to try to use another gmail smtp url and see if it will work again.
Avatar of jddebug

ASKER

I would have given an A grade but your answer was not enough to solve my problem.

You were correct about it not needing authentication btw. :)

From the start it seems it is a gmail server address issue and it took a long call to tech support to get it working. It still puzzles me why it doesn't work the way you suggested.

Many thanks.
Avatar of askirkland
askirkland

You probably figured out the answer by now... but this video solved my Gmail SMTP issues w/ my Sonicwall.  Video
Just tried the several solutions (including Video link) and here's what work for my sonicwall...

Mail Server Settings
Mail server: gmail-smtp-in.l.google.com
From email: user@gmail.com
Authentication: None

Advanced
Port: 25
uncheck "Enable SMTP Authentication"

the To: and From: adresses have to be gmail emails, per the explanations above.
comment above worked like a charm for me

thanks!
puas comment worked great for me.
Hi all,

It is not working with me.

User generated image
User generated imageThanks,
Hai.Duong