Link to home
Start Free TrialLog in
Avatar of Axter
AxterFlag for United States of America

asked on

Accessing computers linked to different routers

I have a main router (Linksys Cable Modem) and two sub routers (Belkin).
The computers linked to the Belkin #1 can not see computers linked to Belkin #2.
I can't even ping them if I use the IP address.
All the computers can see the one computer which is linked directly to the (Linksys) main router, but I have to use the IP address to access it.

I have disable the Firewall setting on both the Belkin routers, and disable the Firewall settings on the computers linked to these routers, but that hasn't help.

1. How can I configure the hardware so all the computers can see each other from  both sub routers?
2. Is there a way for the computers in the sub router to be able to see computers on the main router without having to use IP address, or modifying the hosts file?
ASKER CERTIFIED SOLUTION
Avatar of Peter Hart
Peter Hart
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Axter

ASKER

They're routers.  I'm using routers because I need wireless feature on both of them, and I'm not aware of any switches which have wireless capability.

I tried disabling DCHP on the sub routers, but they fail to get an IP address when I do this, even after I do a reboot.
When I issue "ipconfig /renew" command I get the following output:
Windows IP Configuration
An error occurred while renewing interface Local Area Connection : unable to con
tact your DHCP server. Request has timed out.
No operation can be performed on  while it has its media disconnected.

When I enable it, the errors go away.

I have the following setup:
Sub router A: (Belkin N Wireless Router)
XP machine (wire connection)
Vista 32b Pro (wire connection)
Vista 32b Home (wire connection)
Vista 32b Home (Wireless connection)

Sub router B: (Belkin Wilreless Router)
Vista 32b Home (Wireless connection)

Main router (Linksys)
Windows 7 x64 (wire connection)
Vista 32b Pro (wire connection)
C:\WINDOWS>ipconfig /renew

Windows IP Configuration

An error occurred while renewing interface Local Area Connection : unable to con
tact your DHCP server. Request has timed out.
No operation can be performed on  while it has its media disconnected.

Open in new window

To work only one box on the system should allocate IP addresses.
I would disable DHCP on all but the main router, then switch every thing off. Then in order
switch on the main router, wait, switch on sub routers, wait, switch on PCs.

if this still doesn't work then the other way, which might work is to configure the range of the IP adddresses on each router to be exclusive but in the same group. i.e.
main router starts at 192.168.1.0  to 192.168.1.10
second router starts at 192.168.1.11  to 192.168.1.20
third router starts at 192.168.1.21  to 192.168.1.30
as long as ther first 3 numbers are ther same  i,e, 192..168.1.x   or 10.0.0.x
that should work.
Avatar of Axter

ASKER

I tried both suggestion, and neither work for me.
I disabled the DHCP on both sub routers, and rebooted the routers.  I also rebooted two machines I was testing with.
The result is that the machines can not find a DHCP, and fail to connect get internet connection.

When I tried to reconfigure IP address set on the two sub routers, I still could not see computers from one sub router to the other.

I also tried a combination of both methods, and that caused router to become non-functional, and I had to reset the router, because it wouldn't allow me to access the router via the router IP address.
are the computers set to get IP addresses automatically?
do the "sub" routers have an option to set them as wireless access points instead of Routers?
Avatar of Axter

ASKER

The computers are set to get ip addresses automatically.

At least one sub router has the option for wireless assess point, and I had previously tried that option, but that caused same problem as disabling dhcp.
thing is - the routers them selves need IP addreses,-alocate the routers some ip addresses,
it will be a matter of timing as awell as configuration.
how do the "sub routers" communicate to the main router? wirelessly?

you can only have on box in the system that allocates IP addresses. so you have to disable the DHCP in all boxes except one.
after that you need to debug.  
check the user guides for ther routers nad chekc the support pages.
ensure the main router withe DHCP enabled is on and powered up first.
You want to keep DHCP on for the sub-routers configuration/setup. Sometimes this is labeled as Internet Setup. This will make sure the sub-routers are getting their IP address from the main router, which should be handling DHCP.

You want to turn off the DHCP Server setting on the sub-routers. This will make sure the main router is the only device handling DHCP.

From the results you mention after turning off DHCP, it sounds like you are disabling it for the router configuration instead of disabling acting as a DHCP server.
Alternatively, you can assign the sub-routers a Static IP address based around the scope that the main router is issuing DHCP leases.

For example:

Main Router IP: 192.168.1.1
Main Router DHCP Scope: 192.168.1.100 - 192.168.1.199

You would then make the sub routers look like this:

Sub1 IP - 192.168.1.2
Sub2 IP - 192.168.1.3

Sub1/2 Subnet - 255.255.255.0
Sub 1/2 Gateway - 192.168.1.1
Sub 1/2 DNS - Can be main router, or other DNS server. If unsure set to Main Router's IP (192.168.1.1)
Avatar of Axter

ASKER

>>thing is - the routers them selves need IP addreses,-alocate the routers some ip addresses,
>>it will be a matter of timing as awell as configuration.
The sub routers are already configured to get IP address from main router automatically.

>>How do the "sub routers" communicate to the main router? wirelessly?
They have direct wire connection to main router.

>>you can only have on box in the system that allocates IP addresses. so you have to disable the DHCP in all boxes except one.
>>after that you need to debug.  
>>check the user guides for ther routers nad chekc the support pages.
>>ensure the main router withe DHCP enabled is on and powered up first.
I've already tried this and checked the sub routers web site, but couldn't find any information to help resolve this issue.
Avatar of Axter

ASKER

>>Alternatively, you can assign the sub-routers a Static IP address based around the scope that the main router is issuing DHCP leases.
I'll try this out this weekend, and report back status.

Thanks
Avatar of Axter

ASKER

I have resolved this issue by disabling the routing feature on the two Belkin sub routers.
I'm not at home now, and I don't remember the technical name for the option.

When i get home I'll get the specifics, and post it.


Disabling the DCHP by itself on the sub routers did not work to resolve the issue.  However, disabling the routing functionality results in also disabling the DCHP.

Since chilternPC comments came closes to answering the question, I will award him the points.
Avatar of Axter

ASKER

Since chilternPC comments came closes to answering the question, I will award him the points.
Avatar of Axter

ASKER

Thank you for your assistance.
I'll post additional details on the workaround to make this PAQ complete.