Link to home
Create AccountLog in
Avatar of abenoni
abenoniFlag for Norway

asked on

Problems installing Filemaker Server 11 on Windows 2008 - Admin Server will not start

I have set up a Windows 2008 Server (SP1) on a Amazon EC2 instance. I try to install Filemaker 11 Server and it seems fine until it tries to start the Admin Server. After the install it opens a web page and tries to load the Admin Console. After a couple of minutes It just says "The FileMaker Server Admin Console Start page is not available....."

In EventViewer I see this error:
"Admin Server process has terminated abnormally" - no more info.

This is what I have tried.

Completetly removed FM Server 11 and Java (32 and 64-bit) and Bonjour. Restarted  and reinstalled from scratch to let FM Server 11 install required 32-bit Java and Bonjour. Cleared Java cache.

I can not see the fmsadmin running in the services panel. I also try to run fmsadmin.exe but it just seems to do something but ends with no error.

I also wonder if I can run both 64- and 32-bit Java at the same time as this is 64-bit Windows2008.
Avatar of Will Loving
Will Loving
Flag of United States of America image

Previous versions of FileMaker Server (10 and 9) have had Admin Console startup issues related to the version of Java installed however I'm not aware of similar issues with version 11. That said, you should check the Java Control panel to see what version is installed. FileMaker's Knowledge base specifically identifies the correct version for FMS 11.0v1 as Java Version 6, Update 16, however, it appears that FMS 11.0v2 installs Java 6 Update 20 and Bonjour 2.0, so it's important to get all your versions aligned. ( http://bit.ly/hEhh9g ) Windows auto-update can sometimes install a later version that then prevents the Java-based Admin Console from launching.

With earlier versions of FMS, you could use the Java Control panel to turn off/roll back incorrect versions of Java, but the solution that usually worked best was to delete ALL versions of Java and then let the FMS installer install the correct one. Alternately you can download and manually install the correct one.  Your issue may still come down to the 32-bit vs 64-bit and I'm still thinking about how that might be happening...
Avatar of abenoni

ASKER

If I go to the control panel I see a 32-bit version Java version 6 Update 23. And also I have in the list over installed programs - Java version 6 Update 21 and another Java version 6 Update 23. I guess these are 64-bit versions. Do I have to uninstall the 64-bit versions of Java? I need them for a.o. GeoServer/Tomcat. How do I respond when Java wants to update then? Like I posted I deleted everything and let FM Server installation install Bonjour and Java. But I did let Java do one update.
FMS 11.0v1 used to require (I'm pretty sure) the 32-bit version of Java though I think it's alright to have both 32 and 64-bit versions installed. I'm unable to find verification about whether that is still the case with 11.0v2. My suggestion would be to remove or turn off the other versions of Java and just confirm that you can get the Admin Console to load with Version 20. Once you know that works you can then add in the 64-bit version of Update 20 and see whether FMS continues to work. Does GeoServer/Tomcat require the Update 23 or just 64-bit?
Avatar of abenoni

ASKER

I have installed FMS 11.0v2 (the latest) and I uninstalled all Java versions and Bonjour, restarted the server, reinstalled FMS and let it install Java and Bonjour. Did not do any Java updates after install. Still it comes to the page loading Admin Console and after a couple of minutes gives an error: "The FileMaker Server Admin Console Start page is not available...."

I have turned off Windows Firewall. I am running Apache 2.2 also. I have no idea why FMS is not working.
What versions of Java do you see when you check the Java Control panel?
Though it sounds like you've already done most of what is mentioned, you might want to check out the existing EE thread on this topic. https://www.experts-exchange.com/questions/26179793/Filemaker-11-Upgrade-No-Access-to-Admin-Console.html
Avatar of abenoni

ASKER

I am running Java 6 Update 20. I also read the other thread about upgrading from FMS10 to FMS11 but this is a fresh install. What I notice is that fmsadmin is not running as a service. There are 2 FMS processes running:
- fmserver.exe *32
- fmheper.exe *32
and service: FileMaker Server

I did not know that fmsadmin runs through TomCat. Is that true? I thought it only needed a Java environment.
Sorry if I was unclear. FMS does not interact with TomCat, I was just wondering about whether TomCat required a particular version of Java.

It might seem obvious, but I assume you restarted the computer after doing the install. I've seen many instances during troubleshooting where the Admin Console won't launch until the machine is fully restarted.
Avatar of abenoni

ASKER

TomCat can run on 32-bit I think, I am not really sure. For now all I want to do is get FMS 11 running. And yes I did a restart after every single uninstall and install. I get answer at port 16000 in a browser. I also do not have the folder "FileMaker" in the program menu. I did many completely reinstalls of FMS11. Is it a bad sign that the program menu is not there? I can see the files though in C:\Program File (x86)\FileMaker\FileMaker Server\
Since this is a new installation of FMS 11 and since FileMaker provides free technical support for any installation issue, I would recommend calling them directly. They will have a larger range of experience and may be able to quickly identify the issue with your particular setup. You may get told by the recording that you have to pay but they won't charge you for install issues.
ASKER CERTIFIED SOLUTION
Avatar of abenoni
abenoni
Flag of Norway image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Glad you got it figured out, I'm sure your note will help others in the future.
Avatar of abenoni

ASKER

I am glad for all help but investigating the error messages and similar FileMaker install errors put me on travk to a solution.
Avatar of abenoni

ASKER

Sorry to say this issue has arrived again. After I installed Apache, Geoserver and Mapserver, the fmsadmin service stopped working again. I am not able to log in again to the FileMaker admin console. I uninstalled all non-Microsoft applications and uninstalled FileMaker 11 along with Bonjour and Java. After restart I tried to install FileMaker 11 as administrator. Still the fmsadmin is not installed and the fmsadmin service is not running. FileMaker support is not able to help me. They point to my virtualization solution. I am running this on a Windows 2008 instance on Amazon EC2. I wonder why that could be a problem. Wonder if any one has similar problems running windows applications on a Amazon EC2 instance. This is a 64-bit instance. Are there i.ex. other Windows images that would be recommended? And what is really the difference between this type of virtual machine vs. a real hardware box?
I was pursuing a similar issue with FM Tech support and was reading back through this discussion. The FMI tech support person (named Will also) noted that your installation of GeoServer and MapServer would have conflicted with FM Server.

As part of the troubleshooting process, he also had me uninstall the IIS "role" and re-install it between un-install and re-install of FM Server. He said that IIS needed to be installed before FMS because FMS saved certain settings within the IIS configuration. I know you're using TomCat, so I don't know how that changes things but it was news to me that you needed to have IIS installed on Windows before installing FMS (at least since FMS9 according the the tech.)

Unfortunately, you solution of using "install as Administrator" did not work for me, despite it being an completely new Admin account on a completely new FM Server install (2008 R2).
Avatar of abenoni

ASKER

Thanks. I am not sure why GeoServer or MapServer would conflict with FM Server. Also there is no mention anywhere in the docs about IIS needed. I am using Apache and have not installed IIS. The problem is that the fmsadmin service is not installed at all. I just wonder what is preventing that part of the installation to succeed. I get no error messages. It just is not installed. Is your server a virtual server or a real box? I ask because FMI tech support hints that is a problem. It seems strange. Anyway, cloud computing is the future. So I find it odd that FM tech support is not familiar with this kind of installation problems.

Since I am even more relying on GeoServer and MapServer to do my work I just dropped any further research getting FM Server 11 to work with this server and waiting for version 12 which supposedly will talk directly to PostgreSQL which I also heavily depend on.

And yes, the "install as Administrator" trick did not work anymore after FM Server broke again.
In my case, when I look in the Task Manager, fmserver, fmhelper and fmadmin are all showing up under processes (though only FileMaker Server appears under Services) indicating that fmadmin IS running. This is a "plain Jane" dedicated Quad-core server at 1and1.com running 64-bit Win Server 2008 R2 and nothing else; no Plesk, no Firewall, nothing.

Solution Found: With FM Tech support I did a test to see if the proper ports were open using the Command Prompt and telnet (you may need to enable telnet first under Windows program features). Using the command prompt enter:

telnet xxx.xxx.xxx.xxx 16000

That's telnet followed by your IP address and then the main FMS admin port number 16000. If you get an immediate blank screen then it worked, otherwise there is an issue with the port. In my case I had to go into the Security Settings (IPSec) and choose "IP Security Policies on Local Computer". I created a specific rule to allow ports 5003, 16000, 16001 and 16004 to be open on TCP for all IP addresses. I also found a default setting that was blocking ALL TCP traffic and turned that off.

Once those changes were made, entering http://localhost:16000 in a browser window got me to the Admin Console and the normal deployment sequence.