Link to home
Create AccountLog in
Avatar of mikey250
mikey250

asked on

LAYER 2 & 3 SWITCH - VTP SERVER WONT TALK TO VTP CLIENT

Hi,  i cant get Layer 2 set a 'CLIENT' to receive vtp server.

- ive done various things like:
- delete vlan.dat - and start from beginning
- configured links so both swithes L2 & L3 are pingable

but still cant get vtp server & client talking to each other!:((

when connecting 2 x 2950 12 port swithes with a straight-thru cable and one switch set as 'server' & then the other set as 'client' ive seen it work 'straightaway', but this was on using default vlan 1
- ive also done it in the passed between L2 & L3, but this time ive created a 'native vlan 99' but also included vlan 1 because without this added to my trunk ports the connection wont work.

the only thing i forget to do although i did it after was add on L3:

int range fa0/19 -20
switchport trunk allowed vlan 1,30,40

one thing i havent been doing is saving the config to startup on some occassions, but when i did i still had this problem.  it may well be this!!

can anyone assist?
distribution-L3---3550-switch.TXT
Layer-2-2950-switch.TXT
ASKER CERTIFIED SOLUTION
Avatar of Don Johnston
Don Johnston
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of mikey250
mikey250

ASKER

so i have to set the 2950 back to 'transparent' and set 'domain' then back to 'client'?

ive waited the 5 mins that vtp takes to update and still nothing.

yes trunk is in place as per config attached.

DSW3#sh int trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/19      on           802.1q         trunking      99
Fa0/20      on           802.1q         trunking      99

Port      Vlans allowed on trunk
Fa0/19      1,30,40
Fa0/20      1,30,40

Port        Vlans allowed and active in management domain
Fa0/19      1
Fa0/20      1

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/19      1
Fa0/20      none
when or when not would i delete the vlan.dat im assuming only when maybe i create lots of vlans and just to clear up config then delete vlan.dat?
apologies my fault, for the trunk (x-over) cables and straight-thru for my 2 host pc attached to fa0/1 on each switch, just set as 'switchport mode access) at this time as just testing!
L3 - sh version - shows 6

L2 - sh version - shows 0

As V2 mode is not set, both my swithes are in apparently in Version 1 mode, obviously as ver 1 & 2 arent compatable.

As for setting both swithes to V2 mode if thats what your suggesting, i was under the understanding that V2 was for :

- Token ring, TLV Values & consitency

regarding - port-channel yes i will be doing this later
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
your comment:
"I'm not certain, but I've never set a native vlan that wasn't also specified in the swi trunk allow vlan command."

1. as far as i know it doesnt need to be set as:
#vlan 99

- #as my instructions say: # spanning-tree trunk native vlan 99 - although the reason for adding this was to give understanding about vlan hopping and not using vlan 1 as native and use 99 instead.

your comment:
I also recommend more than 1 switch run in VTP server mode.  Server mode means the switch can change the VLAN info.

i didnt realise more than one switch could be set as 'vtp server mode'

- how would you identify which one is the primary and the secondary or even 3rd or 4th, as your suggestion?

theres more to this than i thought, but good to know this!!!!!!!!!!!
You're correct. There's really no practical advantage to VTP v2. I'd leave them at v1.
hi donjohnston,  yes done: #sh vtp pass - and yes set on L3 as expected, obviously L2 set as client so not set anything as client doesn't allow this.
does anyone know how to set more than 1 vtp server up ie 2, 3, 4

#spanning-tree vlan 1,20,21,22 priority 4096,

then 8192 and so on with multiples of 4096, but as long as below 32768 as this setting would be for the out of the box switches using their default settings.  is this correct?
someone has mentioned about dual stack so i wasn't sure if this was a more efficient way of increasing the number of vtp servers, then.  can anyone shed any light or is my previous comment the correct answer?
Well then, something's obviously not right. Let's start with the basics.

Do the "show int trunk" command from both switches and verify that the trunks are there.

Next, the VLAN 1 interface on the 3550 and the VLAN 1 interface on the 2950 have IP addresses for different networks.  Change one of those so that they are on the same IP network. Then between the two switches to verify that traffic is flowing over the trunk.
>does anyone know how to set more than 1 vtp server up ie 2, 3, 4
>#spanning-tree vlan 1,20,21,22 priority 4096,

You're confusing VTP with STP. They are completely unrelated.

Dual stack doesn't have anything to do with VTP either.

Let's focus on the VTP issue and get it working before adding in any new complications.
You mean running more than 1 VTP switch running in server mode?  
I typically, have the switch start in client mode and verify using sho vtp stat that all the VTP stats match the existing switch in VTP server mode.  From there, I simply run  vtp mode server to make it a "server"  which means it has the ability to add/change/remove VLAN configuration.  Clients are read only and server mode switches have change access.  I am not aware of any method to see how many switches are running in server mode short of loging into each switch and running sho vtp sta to see what mode they are running in.

It isn't for efficiency as much as redundancy since VTP clients don't write the VLANs to memory.
hi donjohnston,

ive added the below command on both L2 & L3:

Mikey: Issue a "switchport trunk allowed vlan add 99"

ive now changed the L2 to - int vlan 1 - ip address 192.168.3.1 255.255.255.0, as L3 is as: int vlan 1 192.168.3.200 255.255.255.0

'sh int trunk' on both L2 & L3 shows:


L3 - DSW3:

sh int trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/19      on           802.1q         trunking      99
Fa0/20      on           802.1q         trunking      99

Port      Vlans allowed on trunk
Fa0/19      1,30,40,99
Fa0/20      1,30,40,99

Port        Vlans allowed and active in management domain
Fa0/19      1
Fa0/20      1

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/19      1
Fa0/20      none
DSW3#

L2 - ASW4:

sh int trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/19      on           802.1q         trunking      99
Fa0/20      on           802.1q         trunking      99

Port      Vlans allowed on trunk
Fa0/19      1,30,40,99
Fa0/20      1,30,40,99

Port        Vlans allowed and active in management domain
Fa0/19      1
Fa0/20      1

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/19      1
Fa0/20      1
ASW4#
hi don,

You're confusing VTP with STP. They are completely unrelated.

Dual stack doesn't have anything to do with VTP either.

Let's focus on the VTP issue and get it working before adding in any new complications.

the only reason for mentioning about the above because another expert mentioned something else!!
Can you ping from the L2 switch to the L3 switch?

Please post the output of a "show vtp status" from both switches along with the current config from both switches.
Sorry. I can't see anything about dual stack and STP in this thread.
ive always been able to ping vice a versa and still can!!
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
i kept on thinking that it was just the 'vtp client' mode was all that needed to be set and 'NOT' the password although it was i think mentioned earlier. so apologies!!

i then did a 'sh vtp status' and the 'vtp pruning' hadn't changed to 'enabled', the same as the 'vtp server', but waited 2 minutes and now the 'vtp pruning' - has changed from 'disable' to 'enabled'.

so yes it has worked now!!! perfect!!!

im going to now repeat this tomorrow and realise my faults again!!  thanks!!
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
correction:

i kept on thinking that it was just the 'vtp client' mode was all that needed to be set and 'NOT' the 'DOMAIN' name, although the password was always set correctly anyway.  so apologies!!

ok!!
one more thing, you mentioned earlier:

Next, the VLAN 1 interface on the 3550 and the VLAN 1 interface on the 2950 have IP addresses for different networks.  Change one of those so that they are on the same IP network. Then between the two switches to verify that traffic is flowing over the trunk.

correct me if im wrong, i thought that as the network is NOT subnetted that my ip address was fine although i changed it as you suggested?
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
so if these 2 different ip addresses were not separated by these 2 switches, what would be the situation, then?
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
ok, but i thought if NO subnetting involved then any address within the private range of of class c, ie:

192.168.0.0 - 192.168.255.254, could be chosen - ie because 1 physical network

but your saying:

- 192.168.0.0 - 1-254 host & 255 - broadcast address

- 192.168.1.0 - 1-254 host & 255 - broadcast address

& so on are classed as on a different network hence my previous address of:

192.168.4.0 1-254 - host & 255 broadcast address

192.168.4.1 255.255.255.0 being incorrect!!! - just want to clear my thoughts on this
you have used this description:  command broadcast domain, although not really heard of this term before!!
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
ok, i will look into this.  i dont actually use a calculator as i normally put pen to paper just for practise and will try that address again tomorrow as nakered now!!!

thanks for all your help anyway appreciated!!!!!!!!!!!!!
yes your right!!
unless subnetted as you have said then i could link both addresses!!
>you have used this description:  command broadcast domain, although not really heard of this term before!!

A broadcast domain is another term for IP network which is another term for VLAN. They all mean the same thing.

Devices within a broadcast domain will receive broadcast frames sent by other devices in the same broadcast domain.
unless it has been left out, VLAN 99 is not created on the distribution switch or the layer 2 switch.  If you set the native vlan to a different vlan other than 1 then that vlan must be present in the vlan database or traffic will not see the vlan and will be dropped.

Make sure the ports are trunked.  Try it without specifying the allowed vlans first and then with the allowed vlans.

As mentioned above Domain and Password need to be the same on all server and client switches.
although MAG03 has commented.  my question has been resolved anyway, but wasn't able to logon as internet connection was down for some unknown reason.  hence closing question now.  thanks though MG03!!!!