Link to home
Create AccountLog in
Avatar of fmalinve
fmalinve

asked on

Can't deploy microsoft office 2007 compatibility pack (fileformatconverters.exe)

Hello experts

I would deploy trough GPO the latest Microsoft Office Compatibility Pack to my users that run Windows XP SP3 with Office 2003 SP3.

I extracted the package using fileformatconverters /extract:[path]
I put the extracted files to a network share with at least READ rights for domain computers and authenticated users groups.
I created the software package and published it to a test user.

The strange thing is that the installation do not start and in the Application event log the following informational event related to the deployed package appears:

eventID: 308
Source: Application Management
Description: Changes to software installation settings were applied successfully.


I can deploy other packages succesfully

thank you



Avatar of Krzysztof Pytko
Krzysztof Pytko
Flag of Poland image

Probably regular user rights are insufficient to install Office. Create software installation GPO in Computer Configuration node and check if during computer startup it installs automatically (and to be sure, you have read&execute rights ?)

Regards,
Krzysztof
I would add the Domain Users permission to read this location. Or the everyone group.


http://mattlog.net/2008/09/12/deploying-office-2007-compatibility-pack-via-group-policy/
Avatar of fmalinve
fmalinve

ASKER

Dear all

for troubleshooting porpouse I set everyone group rights to "Full Control" so we can exclude authorization problems.
I tried to deploy the package to the computer instead of the user and the installation does not start. There's always the same informational event in the application log though related to NT AUTHORITY\ SYSTEM account instead of the domain user.
Moreover I tried to install the package by impersonating the SYSTEM ACCOUNT (I scheduled an interactive cmd.exe job) and the package has been correctly installed.

I turned on the MSI log but no MSI log file is generated but when I launch the MSI package manually, a MSI log file is written.

Run GSOP
To dariusg: What is GSOP?
You run these tools to see if the GPO is actually applying. Have you looked over the link I posted to make sure all steps are taking place?
OK, when you changed GPO installation to Computer, have you linked a GPO to OU where are computer objects? It is computer setting not user, so to be sure, when you deployed package in Computer Configuration node -> Software Installation, you linked it to OU with computers, right? And you do not use any group policy filtering on that GPO?

Krzysztof
Yes, I came through that link me too. I  duly followed it.
The GPO is applied because if I run GPUPDATE / Force on the client machine, it asks me to restart the PC.
In the GPEDIT console I can also see that policies is applied.
To iSiek: Yes. Moreover another package deployed using the same policy is correctly installed ,during startup, on the same PC where I have the error.

It seems to be something related to the package, maybe because it has been extracted by a .exe file, but if I run it from a system account command prompt , it works
OK, try this way. Download free Orga MSI editor and check if there are no parameters which disallows unattended installation (?)

http://www.technipages.com/download-orca-msi-editor.html

Modify MSI, save it and check once again.

Krzysztof
To iSiek:

This tool is quite interesting but I've never used it before. Could you guide me to the parameters should I check that may disallow unattended installation?
OK, I opened MSI package in Orca and there is no parameters that don't allow unattended installation. But I have one more question, have you deployed to the network share all extracted files from fileformatconverters.exe or only the MSI package? To be able install it there should bee all files with folders structure as is.

Krzysztof
OK, I've tested it in my test environment and works fine! Now I cannot prepare doc but tomorrow I will post guide. You can follow and check each step and compare. After that check if it works

Krzysztof
ASKER CERTIFIED SOLUTION
Avatar of Krzysztof Pytko
Krzysztof Pytko
Flag of Poland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.