Link to home
Create AccountLog in
Avatar of FFNM IT
FFNM ITFlag for United States of America

asked on

Cannot access Active Sync Web Administration tool

I am trying to get the Active Sync Web Administration Tool up and running on an Exchange Server 2003 standalone server. We are not running Exchange OMA under the "Default Websites" . There does not appear to be a new virtual directory installed for Mobile Admin.

When I try to access through the link: https://mailserver/mobileadmin, it hits the server as it advises me that there is a problem with the certificate. I then get a 404 error.

I have tried using install mode with no luck. Any idea how I can get this to work?

Let me know if you need more information.
Avatar of pcsmitpra
pcsmitpra
Flag of India image

Is it a newly build IIS server? Please see if asp.net is registered on the server and its web service extension is allowed in IIS.
Is it a newly build IIS server? Please see if asp.net is registered on the server and its web service extension is allowed in IIS.
Locate asp.net 2.0 on the command prompt , C:\windows\microsoft.net\framework\asp.net2.0.xxxx\
and run
aspnet_regiis.exe -i

Restart the IIS and try to browse the link again.
Avatar of FFNM IT

ASKER

This is not a newly built IIS Server, however, I did run through the steps you mentioned to no avail.

I am attaching a screen shot of IIS. I see a virtual directory that references Microsoft-Server-Active-Sync, but nothing regarding Mobile Admin.

We do have users who are connecting to the server with I-phones and droids, but I will have to restrict that if we can't find a way to remotely wipe those devices.

Thanks in advance.
iis-setup.jpg
I believe you have done the asp.net 2 registration and reset IIS. And has allowed the asp.net 2 web service extension.
Do you see any error in event viewer?
Avatar of FFNM IT

ASKER

Yes, ASP.net2 web extension is allowed in IIS.

Here is what I found in the event viewer.
  "Failed while restarting W3SVC.  Error code: 0x8007041d"
Source: ASP.NET 2.0.50727.0

Then after that I saw this successful alert:
Finish registering ASP.NET (version 2.0.50727.0). Detailed registration logs can be found in C:\DOCUME~1\adminrmm\LOCALS~1\Temp\1\ASPNETSetup_00000.log
Source: ASP.NET 2.0.50727.0
Please create a New application pool and change the pool for Active_Sync to this new one. Restart that app pool. and try to browse it
Avatar of FFNM IT

ASKER

I did as you suggested, and tried to browse both locally: https://localhost/mobileadmin
andfrom a client: https://mailserver/mobileadmin.

When I try to browse from IIS it says page cannot be displayed.

I have been tweaking this for 2 days now. I am wondering if maybe I should uninstall and reinstall the Active Sync Administrator?
Please uncheck the "Show Friendly message" from IE -> internet option -> Advance and then see the actual error.
Also place e test .net 2 page and see if .net is working.
I believe its asp.net 2 issue if asp.net runs it will be running.
Avatar of FFNM IT

ASKER

attached is the exact error message received.

I am not familiar with how to add a .net2 page. Do you have a link to a page with instructions on adding one?
error.jpg
Go to iis -> website expand it , Go to exchange -oma , right click properties
asp.net tab
Please make sure asp.net 2.0 is selected there , if not then select it , Apply , ok.
It will reset new app pool also.
Avatar of FFNM IT

ASKER

.net2 was selected, but I reapplied the settings.

As a side note. I was just informed that mobile phones are no longer connecting to exchange. (the one referenced was an I-phone.)
ASKER CERTIFIED SOLUTION
Avatar of pcsmitpra
pcsmitpra
Flag of India image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of FFNM IT

ASKER

Just did, all settings are the original. Back to .net1 and the original application pool settings.

Phones are connecting now.