Link to home
Create AccountLog in
Avatar of Chris
ChrisFlag for United States of America

asked on

10 User Maximum Connection Limit in Windows 7 Ultimate

I upgraded a computer to Windows 7 Ultimate from Vista to get around the 10 user maximum connection limit.  Apparently the maximum connection limit in Windows 7 is 20 users instead of 10.  However, when I use "net config server" in Windows 7 Ultimate, it still shows the limit as 10 users.  I get an error when the 11th user tries to connect to the computer.

How do I set the connection limit to 20?
Avatar of PowerEdgeTech
PowerEdgeTech
Flag of United States of America image

I get 20 in Enterprise x86 and Professional x86 ... I did nothing extra to enable them.  Did you do an in-place upgrade or a fresh install of 7?
Avatar of Chris

ASKER

I did an in place upgrade to Windows 7 x86
I've seen things not work as they should after in-place upgrades.  I don't have any here that I have "upgraded", as I've done fresh installs/image installs on all our upgrades.  Two 7x86 Pro and one 7x86 Ent both show ok here.  I'm can't think of a fix, short of drastic (fresh install).
Avatar of Chris

ASKER

Unfortunately a fresh install isn't really an option at this point.  Surely there must be some way to fix this without a fresh install.  I'll keep looking...
I don't know how you view patches, but I have used  this one effective and it works well.

some will frown, but some will get it.

Remove Win 7 Connection Limit


TCP-Z, Best TCP/IP Patch
Avatar of Chris

ASKER

FirstSentinel - Thanks for the links.  The links you shared appear to help remove a TCP connection limit imposed by Windows.  However, I believe this is different from the file sharing (SMB) limit imposed by Windows.  The TCP-Z patch doesn't claim to remove the SMB / file sharing limitation of Windows.

While it doesn't seem to be the answer to my problem, I do appreciate the contribution - I learned something new about TCP limitations.  Thanks!
ASKER CERTIFIED SOLUTION
Avatar of Chris
Chris
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of Chris

ASKER

This is the solution that worked for me.