Link to home
Create AccountLog in
Avatar of Dan
DanFlag for United States of America

asked on

Terminal server printer redirection fails

I am running windows sever 2003 R2 standard edition terminal server and I have clients that when they log on to the server, their own default printers are not the default printers when they log on to the TS server.  How do I configure the server to make the default printer of each person the default printer for their own session?
ASKER CERTIFIED SOLUTION
Avatar of Krzysztof Pytko
Krzysztof Pytko
Flag of Poland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of Dan

ASKER

Will, what I want done is, for each user that logs on to the terminal server, I need the server to make their own default printer the default printer for their own session.  If there's 2 different users at the same time conencted, and they both have different default printers, their each printer needs to be a default for each one.  Am I making myself clear of what I'm asking, or is it consuing?
Avatar of Dan

ASKER

OK, I disabled "do not set default client printer to be default printer in a session" and "do not allow client printer redirection".  They are both disabled, is there something I need to enable?
At my company we do not use GPOs to manage printer redirection, we just use the RDP-TCP properties to manage that.  We have network printers set up for most of our customers, so we usually uncheck the option "Default to the main client printer" in order to force users to get the default printer assigned to them.

But, since you're using GPOs, I think those 2 settings would be enough.   I don't think there's anything else to enable.

I'm not 100% clear on what exactly is going on.  So, is the problem that the default printer isn't showing up at all? Or, does it show up & it's just not set as the default?

If the default printer isn't showing up at all, there are other things you can check.  At the time the user logs on, do you see Event ID 1111 errors in the system event log?  If you do, then that means the driver needed for the redirected printer isn't installed on the terminal server.  You can resolve that by just installing the driver on the TS.
Avatar of Dan

ASKER

As tested it, it seems to be working, but it's still not working for the user.  I'll try it later with the user again, but for them, they have a network printer, not a local printer and I don't think it will work with a network printer.
Is the "network" printer connected directly to the local network and installed on the client PC using an IP address?

If it is, there is a known issue with printers that have port names that do not begin with LPT, COM or USB not being redirected. That is by Microsoft's design (Lord only knows why).  So, this effects all networked printers that users connect to by IP (the port name usually start with "IP_") or any multi-function printers with a DOT004 port.

Here is a KB article that describes how to force all printers to be redirected, regardless of the port name:
http://support.microsoft.com/kb/302361

On the client PC, just follow the directions to add the FilterQueueType value to the registry.  I don't think you really need to reboot the PC afterward, despite what the article says.  You just need to log off the server & log back on to see the change.
Avatar of Dan

ASKER

When I go to that registry location, there's no default folder, so where do I go instead?
I think that key gets created when a user first connects to a terminal server.   Who was logged on to the computer when you went to that part of the registry?  The user effected by the issue will have to be logged on for you to be able to edit that.

HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR

If the user's access to the registry is restricted, you'd either have to edit the registry using admin credentials or create a VBS script to add that DWORD value.
Avatar of Dan

ASKER

I understant, the problem is that under:
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client

There is no "default" folder. Do I need to create a default and addins folder?
Right, I understand what you're saying.  My question was this:  when you edit the registry, are you logged on using the same account that's having the problem with the redirected printer?  Since this key is under HKCU and HKLM, the keys depend on which user is logged on.

If the keys just aren't there, I think you could create them manually, but it's weird they're not there.

If you logged on with another account, I think you can still edit that portion of the registry as long as the user is logged on as well. I've never tried it in XP, but I think if you just switch to your account while that other account is still logged on, you could edit the same key in this location:

HKEY_USERS\.....user's SID..\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR

If there are just two of you logged on, it should be easy to figure out which SID belongs to whom.

By logging on to a remote server using RDP several times, I did  some tests to see when that key gets created.

In HKEY_CURRENT_USER\Software\Microsoft\, the Terminal Server Client key did not exist at all.  It was NOT created when I logged on using RDP without the printers option checked in the RDP connection properties.

HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default was created when I launched an RDP connection, but didn't log on.

HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\Addins\RDPDR  was created after I logged on to the remote server.

So, if you are logged on with that user's account, I would also be sure that the local printers option is checked in the RDP connection properties. That would explain why that key wasn't created.

Alicia