Link to home
Create AccountLog in
Avatar of HomelandSecureIT
HomelandSecureIT

asked on

outlook anywhere in exchange 2003

i have followed the steps to setup outlook anywhere on exchange 2003, but i cannot get outlook to connect from outside of the company. it works great inhouse. Please help.
ASKER CERTIFIED SOLUTION
Avatar of Alan Hardisty
Alan Hardisty
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Can you provide the steps that you followed, or  a link to the site where you obtained the steps?

Are you running this on SBS2003, what version of Outlook are you using, have you installed a certificate? if so was it purchased or self signed?  Are you configured to use a proxy server?  Have you set your firewall to allow/forward traffic from your external IP address to your Exchange Server?
Did you reboot the Exchange Server after the configuration? There's a specific registry key that requires the server to be restarted before the RPC/HTTPS changes will take effect.

If you're trying to do this over HTTP and not HTTPS you have to do 2 different things and reboot the server:

1. In Internet Information Services (IIS) Manager expand Web Sites, expand Default Web Site, right-click Rpc, and then click Properties.
2. Click the Directory Security tab, and then click Edit under Secure communica- tions.
3. Click to de-select the Require secure channel (SSL) check box and the Require 128-bit encryption check box.
4. Click OK, click Apply, and then click Ok.
5. You must add a DWORD key to “HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\Rpc\RpcProxy” named “AllowAnonymous” and give it a value of 1 (insecure connections will not work without this key).

Avatar of HomelandSecureIT
HomelandSecureIT

ASKER

Have you looked at the Petri Article I linked and downloaded the tool, then run it on the server and set the registry settings with it?

That may simply and quickly resolve your problems.
alanhardisty,
 i did look at the article and downloaded the registry tool and ran it. i also opened those ports on my cisco asa5505.
You need to make sure you've done this registry change per the instructions posted above:

1. On the RPC proxy server (i.e. your Exchange server - this is a single server scenario), start Registry Editor.
2. Locate and then click the follow- ing registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\ RpcProxy
3. In the right pane, right-click ValidPorts, and then click Modify. Note: The default value for the ValidPorts key is: ServerNETBIOSName:100-5000 Where ServerNetBIOSName is the NetBIOS name of your server.
4. Remove all the information from the Value data box, and then type the following information: ServerNETBIOSName:6001-6002;ServerFQDN:6001-6002;ServerNetBIOSName:6004;ServerFQDN:6004

Replace ServerNetBIOSName with the NetBIOS name of your server. Replace ServerFQDN with the fully qualified domain name (FQDN) of your server. Note: The above text is ONE LONG LINE. Copy and paste it into Notepad, and edit it there. Once done, copy it from Notepad and enter it in the Registry editor. Some guides and articles instruct you to also add the external FQDN of the RPC Proxy, i.e. the FQDN used to access the server from the Internet.

Also, check this post: http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/60b495b5-ae79-4232-a2c8-a3b652260731
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
The tool in the article I have linked to will set the registry key correctly and does so without having to play with the registry via regedit.  Much safer IMHO.
@alanhardisty - I agree for sure.

Still no confirmation if the server has been restarted.
rebooting now. will report when it is back up.

Thanks
server has been rebooted and i get the same error doing the connectivity test.

  Attempting to ping RPC endpoint 6004 (NSPI Proxy Interface) on server 2k3server.
  The attempt to ping the endpoint failed.
   Tell me more about this issue and how to resolve it
   Additional Details
  The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process
 
 
You may want to verify that the "NSPI interface protocol sequences" String is in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\ Parameters
here is the result of the RPCping

RPCPinging proxy server mail.bierrebiusa.
Sending ping to server
Response from server received: 200
Pinging successfully completed in 860 ms
Make sure you quit and relaunch Outlook before retrying...give it a whirl now after your server has had a chance to completely start up. Also, maybe try and start from scratch in Outlook with a new profile.
Did you run this command?

rpcping -t ncacn_http -s YourExchMBXServer -o RpcProxy=YourRPCProxyServer -P "user,domain,PASSWORD" -I "user,domain,PASSWORD" -H 1 -u 10 -a connect -F 3 -v 3 -e:6004


This is the port in question.
i got
invalid option e, missing required parameter.

i checked the registry and the multistring value is there with ncacn http:6004
it needs to be
ncacn_http:6004

Open in new window

that did the trick. thanks for all your help. outlook anywhere is now working correctly.