Link to home
Create AccountLog in
Avatar of compdigit44
compdigit44

asked on

Windows 2008 DCDiag Error Missing msDFSR-ComputerReferenceBL

I have a Windows 2008 domain running in 2008 forest and domain mode. When I run DCDiag /C..

Everything passes except I get an error message that that a value is missing for msDFSR-ComputerReferenceBL

This domain used to be Windows 2003 and was raised to 2008 about a 11/2 years ago. Everything in AD is working fine from what i can see..

What is msDFSR-ComputerReferenceBL . When I look at this value in ADSIEDIT it's blank..

Should I be concerned about this
Avatar of Mike Kline
Mike Kline
Flag of United States of America image

When you went from 2003 to 2008 did you migrate from FRS to DFSR (for sysvol).  See this thread over on the TechNet forums  http://social.technet.microsoft.com/Forums/en-US/winserverDS/thread/2ce07c3f-9956-4bec-ae46-055f311c5d96

They linked to several Technet articles.  

Thanks

Mike
Avatar of compdigit44
compdigit44

ASKER

No sure if I migrated FRS to DFSR... How can I tell which one I'm using
Also is this dcdiag error serious???
Could be serious
ok..

I guess I'm confused... How to I know if my 2008 domain is using FRS or DFRS...

How do I know if replication is working??????
Run repadmin /syncall

Post the whole dcdiag
when I ran the repadmin /synall command is stated it finished successfully with out errors..

Does this mean my replacation is working if so should I disregard the dcdiag error message also how do I know if replicatin is using FRS or DFRS.
I'm trying to find a command that tells you if it is definitely using FRS or DFSR,  may have to test later in my lab at home that has 2008 R2 on it.
To be honest I'm not for sure to know what the domain is replicating in. I'm running a blank but if you didn't migrate which you should then you are most likely running FRS. To check your current state of the migration might give you some incite as well dfsrmig /getglobalstate

http://technet.microsoft.com/en-us/library/dd640019(WS.10).aspx

Here some more information in this link.
Post full dcdiag as well.

Run metadata cleanup to make sure you remove any lingering objects

http://www.petri.co.il/delete_failed_dcs_from_ad.htm

http://support.microsoft.com/kb/312862
I cannot post the result of the dcdiag for security reasons..

Anyway if i didn't migrate to DFRS then I must still be using FRS.. If this is the case then I an ignor the dcdiag error message stating the vault in the msDFSR-ComputerReferenceBL

 entrying is missing..

Am I correct??????????????
No you are not correct. Again you can change the name of your DC in the dcdiag but without this it will be hard to pin-point that actual issue.

Have you ran the above steps in the links I posted?
Ok I ran the dfsmig /getglobalstate command and it stated the DFRS migration has not yet started...


Here is the old part of my dcdiag that fails... Please note this domain has 2 DC's..

Directory Server Diagnosis

Performing initial setup:
   Trying to find home server...
   Home Server = Server1
   * Identified AD Forest.
   Done gathering initial info.

Doing initial required tests

   Testing server: HQ\Server1
      Starting test: Connectivity
         Message 0x621 not found.
         Got error while checking LDAP and RPC connectivity. Please check your
         firewall settings.
         ......................... Server1 failed test Connectivity

Doing primary tests

   Testing server: HQ\Server1


   Running partition tests on : DomainDnsZones

   Running partition tests on : ForestDnsZones

   Running partition tests on : Schema

   Running partition tests on : Configuration

   Running partition tests on : domain

   Running enterprise tests on : domain.org
Are you running a network team?
On my physical server yes and my Vmware Vm based DC's NO
I have seen the above error connected to Network teams when running dcdiag.
ASKER CERTIFIED SOLUTION
Avatar of Darius Ghassem
Darius Ghassem
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Cool..

So it's a false positive...

I guess everything is ok then correct???
Yes, everything is correct