Link to home
Create AccountLog in
Avatar of John Shannon
John ShannonFlag for United States of America

asked on

No incoming internet email


I am supporting a Windows 2003 SBS server. This server has been working well for several years. Last week we switched from a local DSL company to a Cable company, (Comcast). The DSL company was hosting a SPAM server called Sentury. The MX record points to this Sentury Server, and the output is sent to our SBS Server.  
Since this change over, we no longer have incoming external email. Outbound works as well as internal email.
Trouble shooting:  Telnet - Ran Telnet from external PC and the screen goes black with a blinking cursor, which isn’t so abnormal, except I was expecting to see the Exchange Header I normally see when performing this operation. Next I ran Telnet from the local PC using IP Address and port as I did with the remote PC. Still the same outcome.  What seems funny to me is I on the screen while its blinking (while running Telnet IPaddr port, If I press the enter key, the telnet operation cancels.
Telnet from a Command Prompt
telnet myserver.com 25
helo customerservers.com
mail from: myemail@myserver.com
rcpt to: administrator@pathwaylighting.com
Response:  This shows me an error 550 5.7.1 “ Unable to relay”
Avatar of Tom Scott
Tom Scott
Flag of United States of America image

Was the MX record changed to bypass the Sentury server?  If not, sounds like you are trying to telnet into it.

Also, I would think the telnet command should be addressed to an FQDN such as mymailhost.mydomain.com.

 - Tom
Your MX record IS still pointing to your old ISP.  They are still receiving your mail, but if you have ceased using them, then you presumably no longer can use them to receive your mail.

Check with your old ISP to see if they can still receive and forward your mail and if not, change your MX record to your new ISP or direct to your own server.

Avatar of John Shannon

ASKER



Thanks for your response.

The MX record was not changed. I also tried circumventing the FQDN by using the IP address of the customers server. That didn't work either.

alanhardisty-

We elected to continue using Sentury. So they really didn't need to change the MX record. Only needed to change the Output to the customers new IP address.
Okay - I was just thinking about the change of IP and whether or not the old ISP was advised about the new IP address.

Is your customer using a new router supplied from the new ISP?

Is port 25 open and ready to receive mail?  Check on www.canyouseeme.org for port 25 - should see SUCCESS if it is.
Also check your SMTP Virtual Server to see if you are only allowing SMTP from certain IP Addresses (those of the old ISP) and call the old ISP to make sure their sending IP Address has not changed.
Hi alanhardisty

The old ISP is hosting the Sentry (SPAM Filter) they are aware of the IP change.

We are using the new router supplied from the Cable company. I did use a utility to verify the ports.
So the Comcast router is configured to port-forward to your internal mail server?

 - Tom
Their router (Comcast) is connected to our Sonicwall firewall. The Comcast does not forward to the mail server but the Sonicwall forwards via port 25.
Is the Comcast router using NAT and non-routable IP internally?  That is the default configuration and would be a problem. Plus, the Comcast router should forward to the SonicWALL or it will not receive inbound messages to forward internally.

 - Tom
Sounds like your new router is not working properly when forwarding the ports and that is what I would be concentrating on.
Can you visit www.canyouseeme.org and do you see the IP Address you expect to see?

Can you telnet to your server on port 25 from a remote computer and can you send a test message via telnet?

http://support.microsoft.com/kb/153119
Tom

I did visit www.canyouseeme.org from the server.
I'm not able to complete a telnet session

On closer inspection, in the ESM under SMTP properties, advanced, Connection I found an IP set for exclusive and the address was incorrect.

Thanks for your help
ASKER CERTIFIED SOLUTION
Avatar of Alan Hardisty
Alan Hardisty
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Alanhardisty - default SMTP Virtual Server

It is working now. Thank you for all your efforts.

John
No problems - what changed?  Was it the IP Address in the SMTP Virtual Server?  If so - what IP Address was it?
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.