Link to home
Create AccountLog in
Avatar of PhilMnty
PhilMntyFlag for United Kingdom of Great Britain and Northern Ireland

asked on

FTP and WSUS error with time-outs over WAN

Over the past few months I have rolled out mutiple windows 2008 R2 (x64) servers accross my WAN, these replaced windows 2003 (x64) servers.

Each of the new servers are running Hyper-V WSUS as a down stream server and FTP services. unfortunatly at about 50% of the sites both WSUS and the FTP services are not working accross the WAN, over the LAN everything works perfectly.

With both the FTP and WSUS services I am receiving time-outs so files are unable to be passed to the server.

This worked fine on windows 2003 and I have sites where it does work with 2008 R2

All the relevent ports are open for both WSUS and FTP but once you request a pull from WSUS it times out the same thing happens when you push to the FTP site.

From my primary site I can take files off the FTP service

I wonder if this is an issue with IIS and the Hyper-V nics?

If anyone has any clues that would be great
Avatar of Justin Owens
Justin Owens
Flag of United States of America image

Do you have any entries in your Event Log or WSUS log to show why it is erroring out?  Initial thoughts are firewalls on the Hyper-V servers hosts or clients as well as making sure the NIC drivers are updated and set up correctly.

DrUltima
Avatar of PhilMnty

ASKER

In WSUS the synch error is

WebException: The operation has timed out.
at System.Net.ConnectStream.Read(Byte[] buffer, Int32 offset, Int32 size)
   at Microsoft.UpdateServices.ServerSync.ServerSyncCompressionProxy.GetWebResponse(WebRequest webRequest)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Microsoft.UpdateServices.ServerSyncWebServices.ServerSync.ServerSyncProxy.GetRevisionIdList(Cookie cookie, ServerSyncFilter filter)
   at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.WebserviceGetRevisionIdList(ServerSyncFilter filter, Boolean isConfigData)
   at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.SyncConfigUpdatesFromUSS()
   at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.ExecuteSyncProtocol(Boolean allowRedirect)

I had the firewalls turned off for testing and still no joy, for me it looks like a routing problem only affecting the WAN. I can take files off the system via FTP over the WAN, but the only way I can send files to the server is with an mstsc connection.

As for drivers on both the working and faulty systems I am running the physical nic as a Broadcom NetXtreme Gigabit Ethernet with the Microsoft driver 10.100.4.0

The virtual nic they are both using are set up in hyper-v as External and allow the management OS to use the nic

maybe removing the virtual nic to see if that fixes the problem is my only option
Maybe, but the virtual NIC should work.  When you say WAN, are you talking about remote sites?  If so, it is possible that your ISP is hosing traffic in some way?  Have you put a network sniffer at either end to make sure FTP packets are sent/received correctly.

DrUltima
FTP looks to be working correctly, no errors in Wireshark, small files can be sent (15KB) but when you sent larger files (20KB) the session time outs, all the time out setting on the server look fine.

taking files off the FTP site is working corectly for all fille sizes.

I dont have access to the router at the remote sites but I am finding it dificalt to pinpoint where the fault is.

On my firewall I dont receive any denials\errors so it is pointing to a windows error but I can't find it
ASKER CERTIFIED SOLUTION
Avatar of PhilMnty
PhilMnty
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
The problem is caused by the network interfaces incorectly auto tuning the speed of the WAN, by disabling the autotuning feature this fixed the issue.

To disable open a command prompt as an administrator and run the dollowing code

netsh int tcp set global autotuninglevel=disabled