Link to home
Create AccountLog in
Avatar of IslandIT
IslandIT

asked on

IBM Total Storage Fiber Channel Tape Drive Replacement

Have a 3582TS box as well as lto ultrium2 tape drive.  The drive went bad and we replaced it with a lto ultrium2.  Problem is when we fired up the TS unit it comes up with Drive 1 invalid call support.  From what I've read it's possibly a firmware issue.  After trying many different avenues for updating the firmware including IBM Total Storage Tape Diagnostic Tool, which finds the drive but will not update the firmware.  See attached photos.   Also tried this tool, ibm_fw_tape_lto2-8571_windows_32-64.exe, and it populated the error attached in photo lto2.  I'm not sure if anyone has changed tape drives and got the error drive1 invalid after and may have a resolution but it would be surely appreciated.  Also I'm wondering if it could be serial number related between tape drives as well.  Just another thought.
 User generated image User generated image
Avatar of Roshan Mohammed
Roshan Mohammed
Flag of New Zealand image

have you updated the drive's firmware, and hba firmware?
ASKER CERTIFIED SOLUTION
Avatar of Thomas Rush
Thomas Rush
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
You need to completely power down tape library.
I have the same problem, i upgrade microcodes religiously but still not good.
You can try powering off and on drive from LCD menus, but for me it worked only against stuck tapes which actually were not.
Avatar of IslandIT
IslandIT

ASKER

@gheist, I have powered down the tape library, which doesn't see the drive so I can't power the drive on or off from the LCD menu.  @selfgovern, I'm going to contact the supplier and see what they say.  I called IBM with the response of them sending out a technician to the tune of $400/hour.  For them to come out and tell me it's the wrong drive or another bad drive isn't worth it with a 3 hour minimum.   Also the light is green and with the diagnostic tool I can get the tape drive to write to a tape through the fiber channel.  Is there anything else to use to update firmware or low level tool to clear and update firmware?  It seems like it doesn't have permissions to write the new firmware when using the tape device firmware upgrade utility.  
Do you have management module installed? You need to sync firmware levels somehow.
One way is to write firmware tape in an old drive and load it into the new drive.
Another is to load latest FW to all componets, if FC is not connected LED display and management module are only options.
3583-TL is manufactured by ADIC which is now Quantum, maybe they have some LTO2 drives around (actually manufactured by HP)
@qheist The old drive doesn't work which is why we're replacing it.  
get ibm to give u a loaner unit, or maybe if you have good relationship with your supplier, get the identical tape drive for a day to test! sounds stupid, but is the best way to eliminate the issues
Or swap tape places or replug cables ;) that sometimes helps to diagnose issues....