Link to home
Start Free TrialLog in
Avatar of vandrie
vandrie

asked on

Pass-through Authentication ICA file not working

I have the following problem:

We want to use a ICA File, for Windows 7 stations to connect to our XenApp6 farm.
No WebInterface, just booting up the machine and automatically start your Citrix desktop.

I have made an ICA File, by connecting to our WI and save the file. Made some moderations and put it on our test machine. The ICA File works like a charm.

But pass trough authentication doesn't work.

Here is my ICA file:
In bold what i have changed trying to get passtrough to work.

[Encoding]
InputEncoding=UTF8

[WFClient]
CPMAllowed=On
ProxyFavorIEConnectionSetting=Yes
ProxyTimeout=30000
ProxyType=Auto
ProxyUseFQDN=Off
SSOnUserSetting=On
EnableSSOnThruICAFile=On
TransparentKeyPassthrough=Local
TransportReconnectEnabled=On
VSLAllowed=On
Version=2
VirtualCOMPortEmulation=Off

[ApplicationServers]
Desktop=

[Desktop]
Address=10.1.0.4:1494
AutoLogonAllowed=ON
BrowserProtocol=HTTPonTCP
CGPAddress=*:2598
"ClearPassword=4AF6B0E376FA57"
ClientAudio=On
DesiredColor=8
DesiredHRES=4294967295
DesiredVRES=4294967295
DoNotUseDefaultCSL=On
Domain=\8C3561F954C0B4B3
FontSmoothingType=0
InitialProgram=#Desktop
LPWD=15
LaunchReference=XH0VjNos7O+Uyrc87IlCB6uV8hu0L93DPxLDqpoLVbU=
Launcher=WI
LocHttpBrowserAddress=!
LogonTicket=4AF6B0E376FA578C3561F954C0B4B3
LogonTicketType=CTXS1
LongCommandLine=
NRWD=31
ProxyTimeout=30000
ProxyType=Auto
SFRAllowed=Off
SSLEnable=Off
SessionsharingKey=-gjiMN5RnAsoqJCWT16NFUB
StartIFDCD=1283499910941
StartSCD=1283499910941
TRWD=0
TWIMode=Off
Title=Desktop
TransportDriver=TCP/IP
UILocale=en
UseLocalUserAnsPassword=On
WinStationDriver=ICA 3.0


Avatar of zoubi77
zoubi77
Flag of Slovenia image

You made one typo - UseLocalUserAnsPassword=On..should be UseLocalUserAndPassword=On
Avatar of TreyBcool
TreyBcool

On your xenapp server - run gpedit.msc - right click on administrative templates and click Add/remove - click Add - browse to \Program Files\Citrix\ICA Client\Configuration and import the icaclient.adm template - in gpedit goto computer config\administrative templates\classic admin temps\citrix components\citrix online plug\user auth and enable passthrough.
Some of the paths may be different based on OS.May need to force a gpupdate.  User generated image
Avatar of vandrie

ASKER

Both options didn't worked. Still got the full in username and password.
You need a few more lines in your ica file
Check out page 92
http://support.citrix.com/servlet/KbServlet/download/80-102-7682/ini_file_reference.pdf

SSOnUserSetting=On
EnableSSOnThruICAFile=On
UseLocalUserAndPassword=On

Avatar of vandrie

ASKER

Nope, still asking username and password ..... I also tried some older clients, but they all have the same problem.
Since you are accessing via the WI do you have pass through enabled via the WI management console under the PN services site?
ASKER CERTIFIED SOLUTION
Avatar of vandrie
vandrie

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of vandrie

ASKER

workarround with appsrv.ini