Link to home
Create AccountLog in
Avatar of Erin_J
Erin_JFlag for United States of America

asked on

windows 7 Power Plan greyed out

In the last few day's my pc won't go to sleep.  When I look in power plans by sleep it says never and is greyed out.  It says see admin.  I am the admin and I never changed any settings.  I've tried signing in under another admin account and it says the same.  I went to group editor under power management and nothing it configured there.  Though I did try to change it anyway but nothing.  I checked start up also and it doesn't appear that anything is running in back ground keeping it from going to sleep.  I recently added a wireless printer to our wireless network and I am wondering if that has anything to do with our computers not going to sleep.  Yes this is not isolated to one computer.  We have 4 computers and none will sleep but they will hybernate.  Any thoughts?  My boss likes sleep mode over hybernate (which it will do).
Avatar of Scottyworld
Scottyworld
Flag of New Zealand image

Do you have group policies set on your PC. These are configured on the server, and not at a local level, and may have been set by the system admin (if thats not you!)

At an (admin elevated) CMD prompt, type GPRESULT /R <enter>
This will list all the policies currently being applied to your PC. Scroll back up the list and there may be an appropriately named one under the Computer Settings section that may indicate a power saving policy has been applied.

If the power settings have been set by GPO then you may not have the rights to change them at a local level
Avatar of McKnife
gpresult will rely on a policy name that says it all, why not take rsop.msc, this will list all policies no matter where they originate from.
Apart from policies there are registry settings. Have a look below HKLM\Software\Policies\Microsoft\Power\PowerSettings
Avatar of Erin_J

ASKER

I am the one and only wanna be admin.  Which means I know more then the rest of the office does about computers.  Anyway, I checked on my SBS as you described and it doesn't show anything about power management or plan.  In fact group policies show mostly "not applied"  so I don't think it has anything to do with my server.  Especially since it is really only serving as a DHCP server right now.  Also one of the PC's isn't even connected to the server and it is doing the same thing.  The sleep mode: never is greyed out.
Avatar of Erin_J

ASKER

Mcknife
okay I'm looking at the reg and I see 3 settings but I don't know which are which.
Avatar of Erin_J

ASKER

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Power\PowerSettings\29F6C1DB-86DA-48C5-9FDB-F2B67B1F44DA
Dword value 0

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Power\PowerSettings\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0
Dword value 3c (60)

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Power\PowerSettings\abfc2519-3608-4c2a-94ea-171b0ed546ab
Dword value 1
ASKER CERTIFIED SOLUTION
Avatar of McKnife
McKnife
Flag of Germany image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Some of the generic Windows 7 VGA drivers do not allow sleep mode. Try updating the display driver from the manufacturer's website and see if the option is still greyed out
Avatar of Erin_J

ASKER

thank you
Avatar of Erin_J

ASKER

Scotty - I learned some from you but ultimately Mcknife's answer fixed it.  Though it is still greyed out I can change it via the registry now.  Thank you Mcknife.
Thanks.
I'm curious: what happens if you delete that value you set and close regedit - still grayed out?
Avatar of Erin_J

ASKER

yes it goes back to never and grayed out
compliments to mcknife re: checking rsop.msc first.  On my SBS 2008 domain, setting computers to never go to sleep when plugged in is a default group policy.  Checking rsop.msc made it much easier to find and eliminate.