Disk Issues

I have two fiber attached SAN drives setup with multi-pathing.  I came back from the weekend and in Computer Management the disks now show up as the screenshot shows.  I have tried to re-initialize, also tried unpresenting and presenting the disks in the EVA.  I'm about to uninstall multipathing and reinstall along with the fiber storport hotfix from Microsoft but I don't hold out much hope for that to work.  The error when i try to reinitialize the disk in Event Viewer reads
Internal Error - The specified plex contains disabled subdisks (C1000078). Disk Management
dtabrown2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin OwensITIL Problem ManagerCommented:
Do the two LUNs show healthy on your SAN from its management?
arnoldCommented:
Why add the software overhead of getting an allocation from SAN and then spanning it on the local server?
i.e. if you needed a single 4TB Drive, why allocated 2 2TB instead of a single 4TB from the SAN

If your SAN is attached to an FC switch, make sure this system is zoned properly.

Check DrUltima's suggestion to make sure the issue is not on the SAN or along the line Switch, Fiber Connection, etc.

Not an initialization of the drive could and likely would lead to data loss.
dtabrown2Author Commented:
The funny thing is I'm not sure why these are showing up...stuck in some wierd cache area in Windows?  The LUNS show as healthy in the EVA...no problems and we haven't  made any changes at all...Just came in one morning to work and it looked like this.  In the EVA I have 3 disks presented to it.  When I unpresent them, these disks still stay here...they don't go away even after a rescan of the disks.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

dtabrown2Author Commented:
Not sure about the spanning part. The guy that maintained this server has since moved on.  In the EVA mngment he has two luns labeled as 'Data 1' & 'Data 2'.  The other is called Shadow.  This is all for Mimosa Email archiving.  NOt sure why anything was designed the way it was.
Thanks.
arnoldCommented:
The issue could be that spanning on the OS is what failed rather than the presentation of the LUNS to the server.
Check he event logs on the server to see whether anything is being reported there about this drive.

Can you bring the two drives online on the windows server?

Is/Are there FC switches between the SAN and the windows HOst?
dtabrown2Author Commented:
Ok when i go into SAN Surfer which is the software for the Qlogic card it says they are both offline. This server is using redundance fiber to redundant switches. That doesn't make sense that they are both showing as "port down"
arnoldCommented:
Check the zoning on the switch.  Either the ports were erroneously disabled, or the association of the port to the correct LUN mapping may have been mistakenly changed. (Check on the switch)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dtabrown2Author Commented:
OK so here is what i have.  I have 1 path to the datastore. no changes have been made anywhere.  I thought there were redundant paths but I was wrong. i think there was a fiber disconnect somewhere and now I have a corrupt disk.  Any ideas or should I just call Microsoft.
arnoldCommented:
The problem with a spanned volume is that corruption on one leads to all data loss.
When the fiber connection has been restored, it sounds as though the state of the span remains offline/corrupt failed.
Presumably/hopefully you have made a backup of the LUNs prior to making any attempts as well as have the backups of the data on the windows systems.
Did bringing both volumes online after the fiber connection was restored and the system booted restore the spanned drive?

Checking with MS might be what you need to do.

dtabrown2Author Commented:
Solution: I was told the zoning was not changed by the person that does the zoning.  It indeed had been changed.  Once the new zone had been added it worked. Granted, after i tried new cables, new sfps, new ports on the fiber switches.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.