Windows 7 Print Spooler repeatedly crashes

Printing was working fine, then one day the print spooler started crashing...

Event Viewer:
Log Name:      Application
Source:        Application Error
Date:          12/01/2011 10:07:10 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      LS-IT.totaleyecare.com.au
Description:
Faulting application name: spoolsv.exe, version: 6.1.7600.16661, time stamp: 0x4c6f61fe
Faulting module name: ntdll.dll, version: 6.1.7600.16559, time stamp: 0x4ba9b802
Exception code: 0xc0000374
Fault offset: 0x00000000000c6df2
Faulting process id: 0x12e0
Faulting application start time: 0x01cbb1e438a67822
Faulting application path: C:\Windows\System32\spoolsv.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: 843cc7c2-1dd7-11e0-a70c-1c6f65914664

Windows 7 Professional 64bit edition.

Attached to one printer (that uses the Samsung Universal Print Driver) shared off another computer on the LAN.

Adobe PDF, Fax & PDFCreator also listed under "Printers and Faxes".

C:\Windows\System32\spool\PRINTERS is empty

sfc /scannow didn't find any errors.
alex_smithAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Stocker06Commented:
Try cleanspl.exe. It's included in the Windows Server 2003 Resource Kit found here http://www.microsoft.com/downloads/en/details.aspx?FamilyID=9d467a69-57ff-4ae7-96ee-b18c4790cffd&DisplayLang=en
0
alex_smithAuthor Commented:
Installed the Resource Kit. Ran the program but got the following error:
The spooler on this computer cannot be cleaned because it is running version 6.1 of Windows NT. Only Windows NT versions 4.0 and 5.0 are supported.
0
AuburnTechCommented:
I am currently dealing with the same situation and have not found a fix yet but a temporary work around.  Create a new shortcut by right clicking on the desktop -> new -> shortcut.  Type "net start spooler" without the quotations as the shortcut location.  Name is as you please and run the file as administrator to properly execute.  Right click the file and select run as admin.  This should restart the print spooler service and your printers should appear again.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

alex_smithAuthor Commented:
Thanks for the suggestion, however, when I restart the computer or just the spooler, it only runs for a few seconds before crashing again. So unfortunately, even having a shortcut as a workaround, isn't going to help.
0
Stocker06Commented:
Maybe try doing it manually. Go to start-run and type printmanagement.msc. Delete all of the drivers and printers present and remap the shared printer with the latest driver and try printing again. Keep in mind, the spooler has to be running when you do this otherwise it won't show the drivers and printers in the management console. You can try starting the spooler from the command prompt with sc start spooler and see if it runs long enough to remove everything.

Also, I wouldn't use the universal driver either if you don't have to. I would use the latest Windows 7 driver for whatever model printer you have.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
alex_smithAuthor Commented:
I managed to open printmanagement.msc long enough to remove some drivers (for printers I no longer use). However, as soon as I go into "Printers and Faxes", the spooler still crashes.

Unfortunately, the only Windows 7 64bit driver Samsung lists is the Universal Print Driver:
http://www.samsung.com/au/support/detail/supportPrdDetail.do?menu=SP00&prd_ia_cd=1703&prd_mdl_cd=SCX-4521F%2FXSA&prd_mdl_name=SCX-4521F&srchword=SCX-4521F

It also won't let me delete it:
The following package(s) can not be deleted:

spd__.inf (x64)
This package contains the following driver(s) that are in use:
Samsung Universal Print Driver; This driver is used on:
   \\192.168.2.222\Samsung Universal Print Driver

The following driver(s) can not be deleted:

Driver Samsung Universal Print Driver (x64) is in use. It is used on:
    \\192.168.2.222\Samsung Universal Print Driver

The plain Windows 7 one was already installed too. I tried to reinstalled it, but it came up with an error: "The arguments are invalid". I've deleted it for now.Print Management
0
alex_smithAuthor Commented:
192.168.2.222 is another computer on the LAN which has the printer attached.
0
Stocker06Commented:
This is a long shot but try replacing this file. Copy it to your system32 folder and allow it to replace the current one.
localspl.dll
0
Stocker06Commented:
Do you have any samsung software installed on the computer besides the driver? Like a print monitor? If so, try removing it.
0
Stocker06Commented:
Hey use the 3.04 driver directly below the Universal Print Driver listed on the link above. It includes a 64 bit driver.
0
alex_smithAuthor Commented:
It won't allow me to move the file into System32. Requires permission from TrustredInstaller to rename existing file. And even running Windows Explorer as Administrator and trying to just overwrite it, doesn't make a difference, I still get "Destination Folder Access Denied".

I've uninstalled everything Samsung related in the "Program and Features" Control Panel but Universal driver still shows in "Print Management".
0
alex_smithAuthor Commented:
I had that on there before, but deleted it. Happy to put it back but won't I need to delete Universal one first?

I'll try deleting Universal driver off 192.168.2.222 and replacing it with normal 3.04...
0
Stocker06Commented:
In printmanagement.msc, will it let you go into the printer's properties under Print Servers>Local>Samsung SCX-4521f or whatever it is listed as, before the spooler crashes? If it will, click on the Advanced tab and then New Driver.. and point it to the 3.04 driver.

You'll need to download that driver and extract it somewhere on your hard drive first of course and then the 64 bit driver should be in \SCX-4x21_Print\Printer\GDI\WINXP_VISTA_64 after you extract it
0
alex_smithAuthor Commented:
It doesn't show up under "Printers" in Print Management, but still there under "Drivers".

It still says it's in use on 192.168.2.222, even though I've deleted it from that computer and replaced it with standard driver.

Will try restarting again...
0
Stocker06Commented:
If it's no longer under printers, try remapping it with the new driver. Does the spooler still crash if you click on Printers and Faxes?
0
alex_smithAuthor Commented:
Finally managed to delete it!

Print spooler appears to have stopped crashing, although I now have no printers installed. Will try installing latest normal Samsung driver....
0
alex_smithAuthor Commented:
Removing the Universal Printer driver and replacing it with a standard one seems to have done the trick...
0
Stocker06Commented:
Great! Glad you figured it out.
0
alex_smithAuthor Commented:
Thanks for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.