Failed to mount mailbox database

MaartenJ
MaartenJ used Ask the Experts™
on
Over the weekend I moved mailboxes to another edb file and after deleting the corrupt one I wanted to replace this with a new edb file on the same location and comes back with this error.

Summary: 2 item(s). 1 succeeded, 1 failed.
Elapsed time: 00:00:00
New Mailbox Database
Completed
Exchange Management Shell command completed:
new-mailboxdatabase -StorageGroup 'SVWEXCH02\First Storage Group' -Name 'Mailbox Database' -EdbFilePath 'D:\Exchange\Database\Mailbox Database.edb'
Elapsed Time: 00:00:00
Mount Mailbox Database
Failed
Error:
Exchange is unable to mount the database that you specified. Specified database: SVWEXCH02\First Storage Group\Mailbox Database; Error code: MapiExceptionADNotFound: Unable to mount database. (hr=0x80004005, ec=2417)
Exchange Management Shell command attempted:
mount-database -Identity 'CN=Mailbox Database,CN=First Storage Group,CN=InformationStore,CN=SVWEXCH02,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=CAK Exchange 2000,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=cak,DC=intra'
Elapsed Time: 00:00:00
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
Trying to see 'Disconnected Mailboxes'

--------------------------------------------------------
Microsoft Exchange Warning
--------------------------------------------------------
Warnings

Get-MailboxStatistics
Completed

Warning:
The database 'SVWEXCH02\First Storage Group\Mailbox Database' to be accessed on server 'svwexch02.cak.intra' is not mounted or is not available.


--------------------------------------------------------
OK
--------------------------------------------------------
Commented:
I have had this when i moved servers and this fixed it.

http://support.microsoft.com/kb/925825/en-us

Author

Commented:
Indeed! MR. Ramsier:

Problem: Insufficient Rights

Sollution

Add the Exchange Servers group to the "Manage auditing and security log" policy
To add the Exchange Servers group to the Manage auditing and security log policy, follow these steps:

   1. Log on to a domain controller by using an account that has administrative rights.
   2. Click Start, point to Administrative Tools, and then click Domain Controller Security Policy.
   3. In the Default Domain Controller Security Settings Microsoft Management Console (MMC) snap-in, expand Local Policies, and then click User Rights Assignment.
   4. In the right pane, double-click Manage auditing and security log.
   5. In the Manage auditing and security log Properties dialog box, click Add User or Group.
   6. In the User and group names box, type DomainName\Exchange Servers, and then click OK two times.
   7. Exit the Default Domain Controller Security Settings MMC snap-in, and then wait for this security setting to propagate across the domain controllers in the domain.
   8. Restart the Microsoft Exchange Information Store service.

Author

Commented:
Problem has been solved and mailbox is mounted...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial