Remote Desktop Protocol error - code 0x1104

I use to be able to connect to my home desktop using my public ip but now I get a protocol error code 0x1104. I can't even do remote desktop on my internal network using my local ip addresses within my network.

Anyone know what it is? I am running on a Windows 7 x64. As far as I know, nothing has changed from my router or desktop since it happened.
LVL 1
rpmcclyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rdmustangCommented:
Did you add a 2nd NIC to the computer?  If so you'll need to configure RDP to listen on the 2nd NIC.

Also, have you tried telnet'ing to 3389 on the remote computer?
Blue Street TechLast KnightCommented:
Are you using the updated RDP client?

In your network try using the computer name instead of the IP? Does that work?

I'm assuming the internal IPs are static or reserved, correct?

Try http://support.microsoft.com/kb/898060
Blue Street TechLast KnightCommented:
Here are some other reasons that may apply:

Case 1: The terminal server is running an application that using the same port as the TS.

Case 2: The server comes with two NICs and each of them has default gateway. That messes the routing table. No computer should have two default gates.

Case 3: The client has XP as Remote Host with DHCP setup. The remote client may receive this error when the Remote host IP changes.

Case 4: I had this problem when i moved a server from a location to another.
My 2003 server has got two NIC and i used one for the first location and the
other for the second location. When i tried to connect with RDP to this server i found this problem. Looking for a solution in Terminal Services Configuration, I've founded it
by authorizing the second Nic to be used for RDP.

Case 5: Some software may changes the port #.
Free and Easy Network Configuration

Network Configuration Generator is designed to make it easy to configure network devices, including Virtual LANs and other advanced features without opening the Command-Line Interface (CLI)! Help boost your network performance, run advanced network scripts, and bypass the CLI.

rpmcclyAuthor Commented:
I havent added a 2nd nic and port 3389 is open.

I have tried to use computer names for the internal RDP but still doesnt work. Yes, the internal IP's are also static. My windows is up to date so I assume its the updated RDP but do not know, can I get that on MS website?

This is on a home network so I dont have a terminal server. I will look at that link you supplied here in a bit.

Is there a way to tell if other programs are changing the port?
Blue Street TechLast KnightCommented:
Which version of Win7 are you running? Basic, Home, Pro, Ultimate, etc.?
You *can't* use Remote Desktop Connection to connect to computers running Windows 7 Starter, Windows 7 Home Basic, or Windows 7 Home Premium – only Pro, Ultimate, or Enterprise.

Can you ping the other static IPs or PC names?

RE: RDP version - yes it is updated via WUS - Windows Update Service.

RE: other programs are changing the port - Disable all firewalls or security software and re-test.

Verify you have the settings set correctly on the receiving machines: http://www.howtogeek.com/howto/windows-vista/turn-on-remote-desktop-in-windows-vista/ 

Finally, add all the users as users to each machine. E.g. Where Computer A, Computer B, Computer C have the corresponding users: User 1, User 2, User 3, then after adding each user to each machine, you would have Computer A which has User 1, User 2, User 3 and so on. After you do this follow the instructions below to add those users to each machine.

1. Open System by clicking the Start button, right-clicking Computer, and then clicking Properties.
2. In the left pane, click Remote settings.  If you're prompted for an administrator password or confirmation, type the password or provide confirmation.
3. In the System Properties dialog box, under Remote Desktop, select one of the three options, and then click Select Users.
If you are an administrator on the computer, your current user account will automatically be added to the list of remote users and you can skip the next two steps.
4. In the Remote Desktop Users dialog box, click Add.
5. In the Select Users or Groups dialog box, do the following:
To specify the search location, click Locations, and then select the location you want to search.
In Enter the object names to select, type the name of the user that you want to add, and then click OK.
The name will be displayed in the list of users in the Remote Desktop Users dialog box.
Dk_guruCommented:
Start at the simplest point;  Make sure that your remote settings have not been changed. (right click on my computer, select properties, select remote settings - make sure that RDP is enabled and allowed.

Check your services to be sure that RDP is running: (right click on my computer, select manage, Select services and Applications, select Services, find Remote Desktop services and make sure it is running (if it is not, right click and start service - if disabled, double click on Remote Desktop Services and select disabled in the drop down and change it to automatic).

Good luck!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dk_guruCommented:
I forgot to mention how to check if it is running: open a command prompt (Windows Key + R) type cmd <enter> at the prompt type:
netstat -a -o |findstr 3389

the | is a pipe the same key (usually) as "\" only with shift...
rpmcclyAuthor Commented:
I'm using Windows 7 x64 Ultimate. Yes, I can ping to other computer names. I haven't tried to update RDP, I will try that and I've tried disabling all firewalls and still doesn't work. All the remote settings are turned on, It was working for a few months and then it randomly wouldn't work. I will try to found out if something else is using the same ports, any easy way to do that?
rpmcclyAuthor Commented:
For some reason the remote desktop had been disabled.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.