?
Solved

No Permissions tab on some shared calendars

Posted on 2011-02-09
12
Medium Priority
?
2,705 Views
Last Modified: 2012-05-11
As in the referenced question, I have several shared calendars that are for resources such as meeting rooms.  Some of them give me the Permissions tab when I right click on the title and go to Properties (in Outlook), and some don't.  I'm the Sys Admin and, or course, I'm a member of the Domain Admins group.

In the previous question from last November, I didn't have SP1 installed and so it was keeping me from using the suggested PowerShell command.  I have SP1 installed now, but I'm running into other problems with the command.

Here's the command I was advised to use:
Add-PublicFolderClientPermission -Identity "\public folder name" -AccessRights Owner -User username

When I enter the command, I get an error stating that no existing 'PublicFolderEntry' matches the Identity I gave it.  I've tried using the entire path found in Object of the properties, I've tried using just the displayed name, and I've tried using the account name of the object, none of which was recognized.  I also tried it with and without the backslash ( \ ) at the beginning of the Identity name.

Obviously I'm doing something wrong.  Perhaps this isn't even the command to use, I don't know.  Any help would be appreciated.

Just a side question: Why did Microsoft decide to go back to command-line only for some tasks?  It's a pain in the rear end to have to learn a whole new set of commands.  I know DOS pretty well, but these commands are nothing like DOS.  I thought GUI interfaces came about to get away from having to learn commands.  Just a rant of mine.

Jono
0
Comment
Question by:Jono Martin
  • 7
  • 2
10 Comments
 

Author Comment

by:Jono Martin
ID: 34855644
When I right-click on the calendar title in Outlook and go to Properties, here are the tabs I get for two different calendars.

  On some I get the Permissions tab
  On some I don't get the Permissions tab
0
 
LVL 15

Expert Comment

by:badgermike
ID: 34855699
you should be able to change them...it sounds like something go bungled up...

I would use the following command

AddUsersToPFRecursive.ps1 -TopPublicFolder "\yourfolder" -User "yourname" -Permission owner
0
 

Author Comment

by:Jono Martin
ID: 34855741
Thanks for replying badgermike.

When trying this command in the Exchange PowerShell, I get this error:
The term 'AddUsersToPFRecursive.ps1' is not recognized as the name of a cmdlet, function, script file, or operable program....
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
LVL 15

Expert Comment

by:badgermike
ID: 34855881
I think you need to navigate to the /scripts folder

c:\Program Files\Microsoft\Exchange Server\Scripts>   ----then run the command from there


Unless you have the exchange scripts folder on a different drive then you would have to navigate to that folder to run it...


0
 

Author Comment

by:Jono Martin
ID: 34855956
I had to use the ".\" to use it, but now it's saying that there's no existing 'PublicFolder' that matches the Identity I gave it.  What TopPublicFolder am I looking for?  I've tried a couple of options, but I'm obviously looking in the wrong place.
0
 

Author Comment

by:Jono Martin
ID: 34873168
Does anyone know how to fix this?  I have some users who need to use these calendars.
0
 
LVL 40

Accepted Solution

by:
Philip Elder earned 2000 total points
ID: 34912968
Perhaps ExFolders can help:

http://msexchangeteam.com/archive/2009/12/04/453399.aspx

Permissions tab may be missing due to non-ownership. This tool gives you full control over the PF setup.

Philip
0
 

Author Comment

by:Jono Martin
ID: 34945226
Sorry for the delay; the office was closed earlier due to weather, but we're back now.

I'll take a look at ExFolders and report back here.
0
 

Assisted Solution

by:Jono Martin
Jono Martin earned 0 total points
ID: 34945938
Well, I did find these resource mailboxes in the tool recommended, but I didn't take the time to learn how to use it.  I did find the solution, however.

The only thing that was needed to allow me to assign permissions to users was to give Domain Admins the Manage Full Access Permission (no idea why Domain Admins don't have this by default).

In EMC > Recipient Config > Mailbox > Right click on the resource mailbox and choose Manage Full Access Permission.  Add Domain Admins to the list and click Manage and Finish.

Once I did this to each resource mailbox (couldn't do a mass change, maybe the tool would have helped) and restarted Outlook on my machine, the Permissions tab was there for each item.

Thanks to EE for the help.

Jono
0
 

Author Closing Comment

by:Jono Martin
ID: 34986542
Solution posted on 21Feb11.
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to fix a SonicWall Gateway Anti-Virus firewall blocking automatic updates to apps like Windows, Adobe, Symantec, etc.
In this article I will be showing you how to subnet the easiest way possible for IPv4 (Internet Protocol version 4). This article does not cover IPv6. Keep in mind that subnetting requires lots of practice and time.
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question