JOOMLA : JFolder::create: Could not create directory JInstaller::install: Failed to create directory while loading a template

Joomla Version: Joomla! 1.5.22 Stable
Operating System: Linux CENTOS 5.x
PHP:   5.1.6
MySQL Database:   5.0.77
Web Server: Apache/2.2.3

I was able to successfully install Joomla and and am able to view both the web site and admin interface using the default templates that come with Joomla.

While loading a new template, I get the following error message:
JFolder::create: Could not create directory  JInstaller::install: Failed to create directory while loading a template

Action Items done at my end so far:
- Searched and reviewed the various postings on this topic
- Set the appropriate directory permissions
- Specified open_basedir=/var/www/html   in php.ini and restarted apache

Still getting these error messages.
Please advise.
Thanks
calieaAsked:
Who is Participating?
 
Amanda WatsonConnect With a Mentor Web DeveloperCommented:
hmm, so you are getting a message saying that you cannot create the folder, but the folder was created?

I think the problem then could be something to do with your server settings.  

You have to change the owner of the folders to the user of the apache server...this is a tricky thing to acomplish and to be honest I always contact the server to help with this.

Sorry I cannot be more helpful
0
 
Amanda WatsonWeb DeveloperCommented:
Hi There,
It could be that you have the tmp folder not set properly
Changed the temporary path to /tmp under global config
A
0
 
calieaAuthor Commented:
Hi,
  The path to temp folder in global config is currently set as follows:
    /var/www/html/flame/tmp

Please let me know if this needs to be changed.
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
Amanda WatsonWeb DeveloperCommented:
is you joomla site in the flame directory?

Is the tmp folder set to chmod 777
0
 
calieaAuthor Commented:

Yes, the joomla site is in the flame directory.
One can access it at http://216.179.19.253/flame
The tmp folder (/var/www/html/flame/tmp) is set to chmod 777
0
 
Amanda WatsonWeb DeveloperCommented:
Can you try enabling the FTP layer and then attempting again.

Your host may have restrictions on  uploading zip files so you may need to do a manual install
0
 
calieaAuthor Commented:

On the Joomla linux server, I started the ftp server.
To confirm access via ftp, from a client machine, I was successfully able to log in using FileZilla.

On the Joomla Linux server, in Admin - Global Config - FTP Settings, I made the following entries:
Enable ftp: Yes
FTP host: localhost
FTP port: 21
username/pw

When I apply the setting, I get the following messages:
FTP::connect: Could not connect to host "localhost" on port 21
Could not make configuration.php writable
(I tried 127.0.0.1 and 216.179.19.253 as well instead of localhost)

If I set Enable-ftp to No, then I do not get the above messages and the config is saved

0
 
Amanda WatsonWeb DeveloperCommented:
You need to make your configuration.php file editable, so change its file permissions to 777, then try again
0
 
calieaAuthor Commented:
chmod 777 had already been done on configuration.php.
Confirmed that it is editable by changing path to temp folder (did this for testing, then reverted back to the desired value) and the updated value is stored in configuration. php.

Also, tried the following :
- Unzipped the new template on local system
- ftped the unzipped files to joomla server folder /var/www/html/flame/tmp
- In joomla admin interface, went to Extensions-Install/Uninstall - Install directory: /var/www/html/flame/tmp
  Clicked on install .Get the following message:
   An error has occurred - unable to create target folder
    I do see the folder com_rocketthemecrystallinetemplateforjoomlabundle folder created in
     /var/www/html/flame/components and in /var/www/html/flame/administrator/components

   The owner of the com_rocketthemecrystallinetemplateforjoomlabundle folder is apache.
    I am using the root as the user and all other folders belong to root.
   
   

   
0
 
calieaAuthor Commented:

Your suggestion in the box above has worked. Changing the owner of the folders to the user of the apache server has resolved the problem that I was having.

  Thankyou for providing the solution.
 
 
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.